zoukankan      html  css  js  c++  java
  • hdu Eddy's picture (最小生成树)

    Eddy's picture

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 29   Accepted Submission(s) : 26

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
    Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?

    Input

    The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point. 

    Input contains multiple test cases. Process to the end of file.

    Output

    Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points. 

    Sample Input

    3
    1.0 1.0
    2.0 2.0
    2.0 4.0
    

    Sample Output

    3.41
    #include <iostream>
    #include<cstdio>
    #include<cstring>
    #include<cmath>
    #include<climits>
    using namespace std;
    const int maxn=105;
    double mp[maxn][maxn];
    double dis[maxn],x[maxn],y[maxn];
    int vis[maxn];
    int i,j,n,l,k;
    double minn,sum;
    
    int main()
    {
        while(~scanf("%d",&n))
        {
            memset(vis,0,sizeof(vis));
            for(i=1;i<=n;i++) scanf("%lf%lf",&x[i],&y[i]);
            for(i=1;i<=n;i++)
                for(j=i+1;j<=n;j++)
                {
                    double d=sqrt(pow(x[i]-x[j],2)+pow(y[i]-y[j],2));
                    mp[i][j]=d;
                    mp[j][i]=d;
                }
         sum=0;
         vis[1]=1;
         for(i=1;i<=n;i++) dis[i]=mp[1][i];
        for(i=1;i<n;i++)
        {
            minn=INT_MAX*1.0;
            for(j=1;j<=n;j++)
                if(!vis[j] && minn>dis[j])
                {
                    k=j;
                    minn=dis[j];
                }
            vis[k]=1;
            sum+=minn;
            for(j=1;j<=n;j++)
             if (!vis[j] && dis[j]>mp[k][j])
                dis[j]=mp[k][j];
        }
            printf("%.2lf\n",sum);
        }
        return 0;
    }
  • 相关阅读:
    一次访问ORACLE数据字典的优化
    利用分区优化SQL
    转行程序员的故事
    有一个苹果
    ubuntu10.04启动后出现grub rescue 模式
    source 命令 && . 命令
    ubuntu10.04启动后出现grub rescue 模式
    Android 各国语言缩写各国语言简称 .
    cpu的核心数、线程数、处理器的位数、操作系统的位数、能够支持最大内存 小结
    产品生产的各个阶段:DV,EV,PV ········是什么意思
  • 原文地址:https://www.cnblogs.com/stepping/p/5723118.html
Copyright © 2011-2022 走看看