zoukankan      html  css  js  c++  java
  • HDU 1260

    Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible. 
    A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time. 
    Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help. 

    InputThere are N(1<=N<=10) different scenarios, each scenario consists of 3 lines: 
    1) An integer K(1<=K<=2000) representing the total number of people; 
    2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person; 
    3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together. 
    OutputFor every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm. 
    Sample Input

    2
    2
    20 25
    40
    1
    8

    Sample Output

    08:00:40 am
    08:00:08 am

    这个递推公式比较简单
    #include <bits/stdc++.h>
    #define M 2009
    using namespace std;
    
    int n,k,a[M],t[M],dp[M];
    int hh,mm,ss;
    
    int main()
    {
    	scanf("%d",&n);
    	while(n--)
    	{
    		scanf("%d",&k);
    		for(int i = 1; i <= k; i++)
    			scanf("%d",&a[i]);
    		for(int i = 2; i <= k; i++)
    			scanf("%d",&t[i]);
    		dp[1] = a[1];
    		for(int i = 2; i <= k; i++)
    			dp[i] = min(dp[i-1]+a[i],dp[i-2]+t[i]);
    		
    		hh = dp[k]/3600;
    		mm = (dp[k]%3600)/60;
    		ss = dp[k]%60;
    		
    		printf("%02d:%02d:%02d %s",( 8 + hh)%24,mm,ss,(8 + hh)%24 > 12 ? "pm
    " : "am
    ");
    	}
    	
    	
    	
    	return 0;
    }
    
  • 相关阅读:
    中国石油大学天梯赛真题模拟第二场
    AtCoder Grand Contest 016 B
    POJ1011 Sticks
    UPC7817: Supermarket
    UPC5652: Ants on a Circle
    石大iCal课表使用指南
    UPC10582: Cowpatibility
    UPC11079: 小P的决斗 POJ3244 Difference between Triplets
    UPC6976:矩阵模板(二维哈希)
    知识点2-3:视图的职责
  • 原文地址:https://www.cnblogs.com/stul/p/10350492.html
Copyright © 2011-2022 走看看