zoukankan      html  css  js  c++  java
  • POJ 1458

    A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

    Input

    The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

    Output

    For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

    Sample Input

    abcfbc         abfcab
    programming    contest 
    abcd           mnp

    Sample Output

    4
    2
    0


    这个题目是一个裸的LCS,现学现用。
    dp[i+1][j+1] = dp[i][j] + 1 (a[i] == b[j])
    dp[i+1][j+1] = max(dp[i][j+1],dp[i+1][j]) (a[i] != b[j])
    #include <iostream>
    #include <string>
    #define M 1005
    using namespace std;
    string a,b;
    int dp[M][M];
    
    int main()
    {
    	while(cin>>a>>b)
    	{
    		for(int i = 0; i < a.length(); i++)
    			for(int j = 0; j < b.length(); j++)
    			{
    				if(a[i] == b[j]) 
    					dp[i+1][j+1] = dp[i][j] + 1;
    				else
    					dp[i+1][j+1] = max(dp[i+1][j],dp[i][j+1]);
    			}
    		cout<<dp[a.length()][b.length()]<<endl;
    	}
    	return 0;
    }
    


  • 相关阅读:
    JavaScript按纯数字排序
    用jQuery监听浏览器窗口的变化
    jquery-jtemplates.js模板应用
    art-template模板应用
    JavaScript判断当前手机是Android还是iOS系统
    JavaScript数组转字符串,字符串转数组
    JavaScript数字转字符串,字符串转数字
    Play framework 安装
    JQuery判断数组中是否包含某个字符串
    js获取页面宽度高度及屏幕分辨率
  • 原文地址:https://www.cnblogs.com/stul/p/10350502.html
Copyright © 2011-2022 走看看