zoukankan      html  css  js  c++  java
  • POJ 2533 裸的LIS

    A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence ( a1a2, ..., aN) be any sequence ( ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8). 

    Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

    Input

    The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

    Output

    Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

    Sample Input

    7
    1 7 3 5 9 4 8

    Sample Output

    4



    #include <iostream>
    #define M 1005
    using namespace std;
    
    int arr[M],dp[M],maxn;
    int main()
    {
    	int n;
    	while(cin>>n){
    		maxn = 0;
    		for(int i = 0; i < n; i++)
    		cin>>arr[i];
    	for(int i = 0; i < n; i++)
    	{
    		dp[i] = 1;
    		for(int j = 0; j < i; j++)
    		{
    			if(arr[j] < arr[i])
    				dp[i] = max(dp[i],dp[j]+1);
    		}
    		maxn = max(maxn,dp[i]);
    	}
    		
    	cout<<maxn<<endl;
    	}
    	
    	return 0;
    }
    
  • 相关阅读:
    execution(* *..BookManager.save(..))的解读
    metalink下载补丁包
    loop_login.sh
    EXPDP IMPDP 知识总结
    图书管理系统简单 过程
    Data Types
    Oracle 创建分页存储过程(转帖)
    绑定变量赋值
    Oracle10g、 Oracle11g完美共存
    Oracle11G 数据库 expdp、impdp使用示例
  • 原文地址:https://www.cnblogs.com/stul/p/10350737.html
Copyright © 2011-2022 走看看