zoukankan      html  css  js  c++  java
  • poj3349 Snowflake Snow Snowflakes(HASH)

    Description

    You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

    Input

    The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

    Output

    If all of the snowflakes are distinct, your program should print the message:
    No two snowflakes are alike.
    If there is a pair of possibly identical snow akes, your program should print the message:
    Twin snowflakes found.

    Sample Input

    2
    1 2 3 4 5 6
    4 3 2 1 6 5

    Sample Output

    Twin snowflakes found.
    题意:给你最多100000朵雪花,每朵雪花有6条边,如果有两朵雪花经翻转/旋转会重合,则输出"Twin snowflakes found."否则输出"Twin snowflakes found."
    题解:只需要hash一下总和,然后遍历总和相同的点,看看是否有重合的雪花
    然而这是一道错题emmm详见discuss
    代码如下:
    #include<queue>
    #include<vector>
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define lson root<<1
    #define rson root<<1|1
    #define hi puts("hi!");
    using namespace std;
    
    vector<int> g[100010];
    int n,a[100005][10];
    
    int check(int x,int y)
    {
        for(int start=0; start<6; start++)
        {
            if((a[x][1]==a[y][(start+1)%6]&&a[x][2]==a[y][(start+2)%6]&&a[x][3]==a[y][(start+3)%6]&&a[x][4]==a[y][(start+4)%6]&&a[x][5]==a[y][(start+5)%6])
             ||(a[x][1]==a[y][(start+5)%6]&&a[x][2]==a[y][(start+4)%6]&&a[x][3]==a[y][(start+3)%6]&&a[x][4]==a[y][(start+2)%6]&&a[x][5]==a[y][(start+1)%6]))
            {
                return 1;
            }
        }
    
        return 0;
    }
    
    int main()
    {
        int flag=0;
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d%d%d%d%d",&a[i][0],&a[i][1],&a[i][2],&a[i][3],&a[i][4],&a[i][5]);
            int key=(a[i][0]+a[i][1]+a[i][2]+a[i][3]+a[i][4]+a[i][5])%99983;
            if(g[key].size())
            {
                for(int j=0; j<g[key].size(); j++)
                {
                    if(check(i,g[key][j]))
                    {
                        puts("Twin snowflakes found.");
                        flag=1;
                    }
                }
            }
            if(flag)
            {
                return 0;
            }
            g[key].push_back(i);
        }
        puts("No two snowflakes are alike.");
    }
     
  • 相关阅读:
    数据建模学习笔记-1-《高质量数据库建模 1-重大意义》
    sqoop中,如果数据中本身有换行符,会导致数据错位
    telnet时显示:允许更多到 telnet 服务器的连接。请稍候再试
    Eclipse首字母快捷设置
    error: bad symbolic reference. A signature in HiveContext.class refers to term hive
    在IT的路上,我在成长
    uglifyjs-webpack-plugin 插件,drop_console 默认为 false(不清除 console 语句),drop_debugger 默认为 true(清除 debugger 语句)
    读《精通正则表达式(第三版)》笔记
    vue cli 3.x 设置4个空格缩进
    正则表达式 学习资料
  • 原文地址:https://www.cnblogs.com/stxy-ferryman/p/8463488.html
Copyright © 2011-2022 走看看