zoukankan      html  css  js  c++  java
  • Codevs 1078 ==Poj 1258 Agri-Net

     
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 53270   Accepted: 22140

    Description

    Description

    Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
    Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
    Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
    The distance between any two farms will not exceed 100,000. 

    Input

    The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

    Output

    For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

    Sample Input

    4
    0 4 9 21
    4 0 8 17
    9 8 0 16
    21 17 16 0
    

    Sample Output

    28

    Source

    #include<iostream> 
    #include<cstdio>
    #include<cstring>
    using namespace std;
    int map[110][110],minn[110],n;
    bool u[110];
    int main()
    {
        cin>>n;
        for(int i=1;i<=n;i++)
          for(int j=1;j<=n;j++)
            cin>>map[i][j];
        memset(u,true,sizeof u );
        memset(minn,0x7f,sizeof minn );
        minn[1]=0;
        for(int i=1;i<=n;i++)
        {
            int k=0;
            for(int j=1;j<=n;j++)
             if(u[j]&&minn[j]<minn[k])
              k=j;
             u[k]=false;
             for(int j=1;j<=n;j++)
             {
                  if(u[j]&&map[k][j]<minn[j])
                    minn[j]=map[k][j];
             } 
        }
        long long tot=0;
        for(int i=1;i<=n;i++)
         tot+=minn[i];
         printf("%lld",tot);
        
        return 0;
    }

    思路:Prim算法 蓝白点思想  minn[i]存放蓝点i与白点相连的最小边权  u[i]=True,表示顶点i还未加入到生成树中  u[i]=False,表示顶点i已加入到生成树中 

    最后累加一遍 Minn即可

  • 相关阅读:
    NET5 ORM 六大新功能
    牛逼程序员必须要掌握金字塔思维
    实体类转Json的2种方法
    怎么使用jquery阻止页面的离开或卸载
    GitHub的用法:到GitHub上部署项目
    搭建个人服务器
    远程服务器上部署本地项目
    java.nio.ByteBuffer中flip,rewind,clear方法的区别
    eclipse Run On Server 异常:could not load the Tomcat Server configuration at Servers omcat V5.0 Sertomcat
    throw与throws的区别
  • 原文地址:https://www.cnblogs.com/suishiguang/p/5931277.html
Copyright © 2011-2022 走看看