zoukankan      html  css  js  c++  java
  • Codevs 1078 ==Poj 1258 Agri-Net

     
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 53270   Accepted: 22140

    Description

    Description

    Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
    Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
    Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
    The distance between any two farms will not exceed 100,000. 

    Input

    The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

    Output

    For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

    Sample Input

    4
    0 4 9 21
    4 0 8 17
    9 8 0 16
    21 17 16 0
    

    Sample Output

    28

    Source

    #include<iostream> 
    #include<cstdio>
    #include<cstring>
    using namespace std;
    int map[110][110],minn[110],n;
    bool u[110];
    int main()
    {
        cin>>n;
        for(int i=1;i<=n;i++)
          for(int j=1;j<=n;j++)
            cin>>map[i][j];
        memset(u,true,sizeof u );
        memset(minn,0x7f,sizeof minn );
        minn[1]=0;
        for(int i=1;i<=n;i++)
        {
            int k=0;
            for(int j=1;j<=n;j++)
             if(u[j]&&minn[j]<minn[k])
              k=j;
             u[k]=false;
             for(int j=1;j<=n;j++)
             {
                  if(u[j]&&map[k][j]<minn[j])
                    minn[j]=map[k][j];
             } 
        }
        long long tot=0;
        for(int i=1;i<=n;i++)
         tot+=minn[i];
         printf("%lld",tot);
        
        return 0;
    }

    思路:Prim算法 蓝白点思想  minn[i]存放蓝点i与白点相连的最小边权  u[i]=True,表示顶点i还未加入到生成树中  u[i]=False,表示顶点i已加入到生成树中 

    最后累加一遍 Minn即可

  • 相关阅读:
    deepsort+yolov3实现多类别多目标跟踪
    WAR2020暑期补题集
    【数据结构】浅谈主席树
    Github本地上传命令
    【蓝桥杯】2017年第八届蓝桥杯C/C++B组省赛——C题 承压计算
    【蓝桥杯】2017年第八届蓝桥杯C/C++B组省赛——B题 等差素数列
    【蓝桥杯】2019年第十届蓝桥杯C/C++ B组省赛——I题 后缀表达式
    防御Mimikatz-转载
    SQL注入之判断数据库
    XPATH注入
  • 原文地址:https://www.cnblogs.com/suishiguang/p/5931277.html
Copyright © 2011-2022 走看看