zoukankan      html  css  js  c++  java
  • ZOJ3708Density of Power Network

    Density of Power Network

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    The vast power system is the most complicated man-made system and the greatest engineering innovation in the 20th century. The following diagram shows a typical 14 bus power system. In real world, the power system may contains hundreds of buses and thousands of transmission lines.

    Network topology analysis had long been a hot topic in the research of power system. And network density is one key index representing the robustness of power system. And you are asked to implement a procedure to calculate the network density of power system.

    The network density is defined as the ratio between number of transmission lines and the number of buses. Please note that if two or more transmission lines connecting the same pair of buses, only one would be counted in the topology analysis.

    Input

    The first line contains a single integer T (T ≤ 1000), indicating there are T cases in total.

    Each case begins with two integers N and M (2 ≤ N, M ≤ 500) in the first line, representing the number of buses and the number of transmission lines in the power system. Each Bus would be numbered from 1 to N.

    The second line contains the list of start bus number of the transmission lines, separated by spaces.

    The third line contains the list of corresponding end bus number of the transmission lines, separated by spaces. The end bus number of the transmission lines would not be the same as the start bus number.

    Output

    Output the network density of the power system in a single line, as defined in above. The answer should round to 3 digits after decimal point.

    Sample Input

    3
    3 2
    1 2
    2 3
    2 2
    1 2
    2 1
    14 20
    2 5 3 4 5 4 5 7 9 6 11 12 13 8 9 10 14 11 13 13
    1 1 2 2 2 3 4 4 4 5 6 6 6 7 7 9 9 10 12 14
    

    Sample Output

    0.667
    0.500
    1.429
    
    -----------------------------------------------------------------------------------
    这题最后求的是公交路线的数量与公交车数量的比例,由于可能存在重复的路线,所以要对数据进行排除,排除已存在的路线。
    #include<stdio.h>
    int main()
    {
    	int t,n,m,i,j,a[505],b[505],temp,m1,flag[505];
    	scanf("%d",&t);
    	while(t--)
    	{
    		scanf("%d%d",&n,&m);
    		m1=m;
    		for(i=0;i<m;i++)
    			flag[i]=0;
    		for(i=0;i<m;i++)
    			scanf("%d",&a[i]);
    		for(i=0;i<m;i++)
    			scanf("%d",&b[i]);
    		for(i=0;i<m;i++)
    		{
    			if(a[i]>b[i])
    			{
    				temp=a[i];
    				a[i]=b[i];
    				b[i]=temp;
    			}
    		}
    		for(i=0;i<m;i++)
    		{
    			for(j=i+1;j<m;j++)
    			{
    				if(flag[j])continue;
    				if(a[i]==a[j]&&b[i]==b[j])
    				{
    					flag[j]=1;
    					m1--;
    				}
    			}
    		}
    		printf("%.3lf\n",m1*1.0/n*1.0);
    	}
    	return 0;
    }
  • 相关阅读:
    蓝桥杯 2014本科C++ B组 六角填数 枚举排列
    蓝桥杯 2014本科C++ B组 地宫取宝 DFS+记忆化搜索
    埃及分数 IDA*
    优先队列详解(转载)
    HDU 1242 Rescue BFS+优先队列
    HDU 1627 Krypton Factor
    2018中国机器人大赛服务机器人专项赛赛后总结
    OpenMP使用体验报告(概述)
    写在归程路上——2018ROBOCUP机器人世界杯中国赛
    ROS编译工作区缺少cv_bridge的问题解决
  • 原文地址:https://www.cnblogs.com/tengtao93/p/3087678.html
Copyright © 2011-2022 走看看