zoukankan      html  css  js  c++  java
  • HDU5670 Machine【进制】

    Machine

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 1586    Accepted Submission(s): 708

    Problem Description
    There is a machine with m(2m30) coloured bulbs and a button.When the button is pushed, the rightmost bulb changes.
    For any changed bulb,

    if it is red now it will be green;

    if it is green now it will be blue;

    if it is blue now it will be red and the bulb that on the left(if it exists) will change too. 

    Initally all the bulbs are red. What colour are the bulbs after the button be 
    pushed n(1n<263) times?
    Input
    There are multiple test cases. The first line of input contains an integer T(1T15) indicating the number of test cases. For each test case:

    The only line contains two integers m(2m30) and n(1n<263).
    Output
    For each test case, output the colour of m bulbs from left to right.
    R indicates red. G indicates green. B indicates blue.
    Sample Input
    2 3 1 2 3
    Sample Output
    RRG GR
    Source

    问题链接HDU5670 Machine

    题意简述:参见上文。

    问题分析:这是一个进制转换问题。

    程序说明:(略)

    题记:(略)


    AC的C语言程序如下:

    /* HDU5670 Machine */
    
    #include <stdio.h>
    #include <string.h>
    
    #define BASE    3
    #define N       30
    
    char rgb[] = "RGB";
    int color[N];
    
    int main(void)
    {
        int t, m, len, i;
        long long n;
    
        scanf("%d", &t);
        while(t--) {
            memset(color, 0, sizeof(color));
    
            scanf("%d%lld", &m, &n);
    
            len = m;
            while (n > 0 && m > 0) {
                color[--m] = n % BASE;
                n /= BASE;
            }
    
            for (i=0; i<len; i++)
                putchar(rgb[color[i]]);
            putchar('
    ');
        }
    
        return 0;
    }




  • 相关阅读:
    WPF中实现Button.Content变化的简易动画
    WPF中ListBox的项ListBoxItem被选中的时候Background变化
    GD库处理图像
    PHP上传文件示例
    会话控制:Cookie和session
    PHP表单与验证
    PHP日期与时间
    PHP正则表达式
    PHP字符串处理
    目录与文件操作
  • 原文地址:https://www.cnblogs.com/tigerisland/p/7563633.html
Copyright © 2011-2022 走看看