zoukankan      html  css  js  c++  java
  • UVALive3261 UVA1640 POJ2282 HDU1663 ZOJ2392 The Counting Problem【进制】

    Time Limit: 3000MS   Memory Limit: 65536K
    Total Submissions: 4605   Accepted: 2363

    Description

    Given two integers a and b, we write the numbers between a and b, inclusive, in a list. Your task is to calculate the number of occurrences of each digit. For example, if a = 1024 and b = 1032, the list will be 
    1024 1025 1026 1027 1028 1029 1030 1031 1032

    there are ten 0's in the list, ten 1's, seven 2's, three 3's, and etc.

    Input

    The input consists of up to 500 lines. Each line contains two numbers a and b where 0 < a, b < 100000000. The input is terminated by a line `0 0', which is not considered as part of the input.

    Output

    For each pair of input, output a line containing ten numbers separated by single spaces. The first number is the number of occurrences of the digit 0, the second is the number of occurrences of the digit 1, etc.

    Sample Input

    1 10
    44 497
    346 542
    1199 1748
    1496 1403
    1004 503
    1714 190
    1317 854
    1976 494
    1001 1960
    0 0
    

    Sample Output

    1 2 1 1 1 1 1 1 1 1
    85 185 185 185 190 96 96 96 95 93
    40 40 40 93 136 82 40 40 40 40
    115 666 215 215 214 205 205 154 105 106
    16 113 19 20 114 20 20 19 19 16
    107 105 100 101 101 197 200 200 200 200
    413 1133 503 503 503 502 502 417 402 412
    196 512 186 104 87 93 97 97 142 196
    398 1375 398 398 405 499 499 495 488 471
    294 1256 296 296 296 296 287 286 286 247
    

    Source


    Regionals 2004 >> Asia - Shanghai


    问题链接UVALive3261 UVA1640 POJ2282 HDU1663 ZOJ2392 The Counting Problem

    问题简述:输入m和n,计算m到n(包括m和n)之间各个数中包含多少个0-9数字。

    问题分析:先分别计算0到m-1和0到n之间数的数字个数,结果=0到n之间数的数字个数-0到m-1之间数的数字个数。计算0到n之间数的数字个数时,先考虑1位数、2位数、......,在小于n的区间逐步统计。

    程序说明:数组radix[]计算存放10进制的位权备用。函数countdigit()用于统计0到n之间数的0-9个数。

    这个程序在POJ中,用C语言提交出现错误,也许是其C语言版本太低有关,用GCC提交可以通过。其他地方用C语言提交即可。

    参考链接POJ3286 How many 0's?


    AC的C语言程序如下:

    /* UVALive3261 UVA1640 POJ2282 HDU1663 ZOJ2392 The Counting Problem */
    
    #include <stdio.h>
    
    typedef long long LL;
    
    #define MAXN 10
    
    LL radix[MAXN+1];
    
    void maketable()
    {
        int i;
    
        radix[0] = 1;
        for(i=1; i<=MAXN; i++)
            radix[i] = radix[i-1] * 10;
    }
    
    LL countdigit(LL n, int digit)
    {
        LL sum=0, dgt, left, right;
        int i;
        for(i=1;;i++) {
            left = n / radix[i];
            sum += (left -((digit==0)?1:0)) * radix[i-1];
            dgt = n % radix[i] / radix[i-1];
            if (dgt > digit)
                sum += radix[i-1];
            else if(dgt == digit) {
                right = n % radix[i-1];
                sum += right + 1;
            }
    
            if (n < radix[i])
                break;
        }
    
        return sum;
    }
    
    int main(void)
    {
        maketable();
    
        int a, b, i;
    
        while(scanf("%d%d", &a, &b) != EOF && a+b) {
            if(a > b) {
                int temp = a;
                a = b;
                b = temp;
            }
    
            for(i=0; i<=9; i++)
                printf("%lld%c", countdigit(b, i) - countdigit(a-1, i), (i==9)?'
    ':' ');
        }
    
        return 0;
    }


  • 相关阅读:
    下雪诗
    华视身份证阅读器100UC HTTP模式二次开发
    C# Action 和 Func 区别
    网站部署——文件系统
    前端-JavaScript DOM和BOM
    IO多路复用
    python-协程
    python-线程
    python-进程
    计算机与操作系统简介
  • 原文地址:https://www.cnblogs.com/tigerisland/p/7564349.html
Copyright © 2011-2022 走看看