zoukankan      html  css  js  c++  java
  • sicily 1007.To and Fro 考察输入的更改

    Sicily

    1007. To and Fro

    Constraints

    Time Limit: 1 secs, Memory Limit: 32 MB

    Description

    Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is "There's no place like home on a snowy night" and there are five columns, Mo would write down t o i o y h p k n n e l e a i r a h s g e c o n h s e m o t n l e w x Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character `x' to pad the message out to make a rectangle, although he could have used any letter. Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as toioynnkpheleaigshareconhtomesnlewx Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.

    Input

    There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2 . ..20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.

    Output

    Each input set should generate one line of output, giving the original plaintext message, with no spaces.

    Sample Input

    5
    toioynnkpheleaigshareconhtomesnlewx
    3
    ttyohhieneesiaabss
    0
    

    Sample Output

    theresnoplacelikehomeonasnowynightx
    thisistheeasyoneab
    #include<iostream>
    using namespace std;
    char a[400][400];
    int n;
    int main()
    {
        string s;
        while(cin>>n && n!=0){
            cin>>s;
            int cnt=0;
            for(int i=0;i<s.size();i+=n){
                if(cnt&1) {                           
                    for(int j=0;j<n;j++)
                         a[cnt][j]=s[i+n-1-j];//cout<<"a[ou][j]="<<a[cnt][j]<<endl;
                }
                else{
                    for(int j=0;j<n;j++)
                        a[cnt][j]=s[i+j];//cout<<"a[odd][j]="<<a[cnt][j]<<endl;  
                }                                                                                                                                                
                cnt++;                                                                                                    
            }
            for(int i=0;i<n;i++)
                for(int j=0;j<(s.size())/n;j++)
                    cout<<a[j][i];
            cout<<endl;
        }    
        return 0;
    } 



  • 相关阅读:
    编译使用luasocket
    使用openssl的一些问题
    c++调用lua注册的带参数的回调
    合服
    windows防火墙命令
    mac os .xip格式解压
    Get GPU Data Method
    Unity编译Mono
    Unity Mono运行机制分析及内存优化
    unity5 AssetBundleBuild用法
  • 原文地址:https://www.cnblogs.com/tinyork/p/3403925.html
Copyright © 2011-2022 走看看