zoukankan      html  css  js  c++  java
  • Cannon

    Description
    In Chinese Chess, there is one kind of powerful chessmen called Cannon. It can move horizontally or  vertically along the chess grid. At each move, it can either simply move to another empty cell in the same line without any other chessman along the route or perform an eat action. The eat action, however, is the main concern in this problem. 
    An eat action, for example, Cannon A eating chessman B, requires two conditions:
    1、A and B is in either the same row or the same column in the chess grid.
    2、There is exactly one chessman between A and B.
    Here comes the problem.
    Given an N x M chess grid, with some existing chessmen on it, you need put maximum cannon pieces into the grid, satisfying that any two cannons are not able to eat each other. It is worth nothing that we only account the cannon pieces you put in the grid, and no two pieces shares the same cell.
    Input
    There are multiple test cases. 
    In each test case, there are three positive integers N, M and Q (1<= N, M<=5, 0<=Q <= N x M) in the first line, indicating the row number, column number of the grid, and the number of the existing chessmen.
    In the second line, there are Q pairs of integers. Each pair of integers X, Y indicates the row index and the column index of the piece. Row indexes are numbered from 0 to N-1, and column indexes are numbered from 0 to M-1. It guarantees no pieces share the same cell.
    Output
    There is only one line for each test case, containing the maximum number of cannons. 
    SampleInput
    4 4 2 
    1 1 1 2 
    5 5 8 
    0 0 1 0 1 1 2 0 2 3 3 1 3 2 4 0 

    SampleOutput
    8 
    9

    题意就是给你一个n*m的棋盘,然后上面已经有了 棋子,并给出这些棋子的坐标,但是这些棋子是死的就是不能动,然后让你在棋盘上面摆炮,但是炮之间不能互相吃,吃的规则我们斗懂得 炮隔山打嘛,问你最多能放几个炮

    法一:并查集

    #include <iostream>
    #include <stack>
    #include <stdio.h>
    using namespace std;
    const int MAX_N = 10000 + 100;
    const int MAX_M = 100000 + 100;
    int p[MAX_N];
    int _find(int x)
    {
        return p[x] == x ? x : (p[x] = _find(p[x]));
    }
    int n, m;
    stack <int> s;
    struct Edge
    {
        int u, v;
    };
    Edge edge[MAX_M];
    int res[MAX_M];

    int main()
    {
        while(scanf("%d%d", &n, &m) != EOF)
        {
            for(int i = 0; i < n; i++)
                p[i] = i;
            for(int i = 0; i < m; i++)
                scanf("%d%d", &edge[i].u, &edge[i].v);
            res[m - 1] = n;
            for(int i = m - 1; i > 0; i--)
            {
                int a = _find(edge[i].u);
                int b = _find(edge[i].v);
                if(a != b)
                {
                    p[a] = b;
                    res[i - 1] = res[i] - 1;
                }
                else
                    res[i - 1] = res[i];
            }
            for(int i = 0; i < m; i++)
                printf("%d ", res[i]);
        }
        return 0;
    }

    法二,DFS

    数据范围很小,明显是搜索。

    主要剪枝,就是不要和前面的冲突了、

    /* ***********************************************
    Author        :kuangbin
    Created Time  :2013/8/24 14:38:00
    File Name     :F:2013ACM练习比赛练习2013通化邀请赛1007.cpp
    ************************************************ */

    #include <stdio.h>
    #include <string.h>
    #include <iostream>
    #include <algorithm>
    #include <vector>
    #include <queue>
    #include <set>
    #include <map>
    #include <string>
    #include <math.h>
    #include <stdlib.h>
    #include <time.h>
    using namespace std;
    int n,m;
    int g[10][10];
    int ans ;

    void dfs(int x,int y,int cnt)
    {
        if(x >= n)
        {
            ans = max(ans,cnt);
            return;
        }
        if(y >= m)
        {
            dfs(x+1,0,cnt);
            return;
        }
        if(g[x][y] == 1)
        {
            dfs(x,y+1,cnt);
            return;
        }
        dfs(x,y+1,cnt);
        bool flag = true;
        int t;
        for(t = x-1;t >= 0;t--)
            if(g[t][y])
            {
                break;
            }
        for(int i = t-1;i >= 0;i--)
            if(g[i][y])
            {
                if(g[i][y]==2)flag = false;
                break;
            }
        if(!flag)return;
        for(t = y-1;t >= 0;t--)
            if(g[x][t])
                break;
        for(int j = t-1;j >= 0;j--)
            if(g[x][j])
            {
                if(g[x][j] == 2)flag = false;
                break;
            }
        if(!flag)return;
        g[x][y] = 2;
        dfs(x,y+1,cnt+1);
        g[x][y] = 0;
    }


    int main()
    {
        //freopen("in.txt","r",stdin);
        //freopen("out.txt","w",stdout);
        int Q;
        int u,v;
        while(scanf("%d%d%d",&n,&m,&Q) == 3)
        {
            memset(g,0,sizeof(g));
            while(Q--)
            {
                scanf("%d%d",&u,&v);
                g[u][v] = 1;
            }
            ans = 0;
            dfs(0,0,0);
            printf("%d ",ans);
        }
        return 0;
    }

  • 相关阅读:
    如何学习新技术
    创建模式之工厂方法模式
    SQL Server 存储过程
    ASP.NET Cache的一些总结
    ACE_TSS研究
    利用Thunk让C++成员函数变回调函数
    ACE内存映射学习
    ACE的初始化
    双检锁模式学习
    ACE_Task笔记
  • 原文地址:https://www.cnblogs.com/to-creat/p/5005077.html
Copyright © 2011-2022 走看看