zoukankan      html  css  js  c++  java
  • hdu1716 STL next_permutation函数的使用

    排列2

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 3712    Accepted Submission(s): 1462

    Problem Description
    Ray又对数字的列产生了兴趣:
    现有四张卡片,用这四张卡片能排列出很多不同的4位数,要求按从小到大的顺序输出这些4位数。
     

    Input
    每组数据占一行,代表四张卡片上的数字(0<=数字<=9),如果四张卡片都是0,则输入结束。
     

    Output
    对每组卡片按从小到大的顺序输出所有能由这四张卡片组成的4位数,千位数字相同的在同一行,同一行中每个四位数间用空格分隔。
    每组输出数据间空一行,最后一组数据后面没有空行。
     

    Sample Input
    1 2 3 4 1 1 2 3 0 1 2 3 0 0 0 0
     

    Sample Output
    1234 1243 1324 1342 1423 1432 2134 2143 2314 2341 2413 2431 3124 3142 3214 3241 3412 3421 4123 4132 4213 4231 4312 4321 1123 1132 1213 1231 1312 1321 2113 2131 2311 3112 3121 3211 1023 1032 1203 1230 1302 1320 2013 2031 2103 2130 2301 2310 3012 3021 3102 3120 3201 3210
     


    这道题目就是使我学会了STL里面的next_permutation的用法。这个函数的功能是得到下一个比当前字典序排列大的排列。数组,字符串都能用。

    可以用作求几个字符的全排列。还有就是这道题目的格式比较坑。此外还有个对应的prev_permutation

    #include <iostream>
    #include <algorithm>
    using namespace std;
    int main()
    {
    	int a[4];
    	int f=0;
    	while(cin>>a[0]>>a[1]>>a[2]>>a[3])
    	{
    		if(!a[0]&&!a[1]&&!a[2]&&!a[3])
    			break;
    		if(f)
    			cout<<endl;
    		sort(a,a+4);
    		int flag = a[0];
    		if(a[0]!=0)
    			printf("%d%d%d%d",a[0],a[1],a[2],a[3]);
    		while(next_permutation(a,a+4))
    		{
    			if(a[0]==0)
    				continue;
    			if(a[0]==flag)
    				printf(" %d%d%d%d",a[0],a[1],a[2],a[3]);
    			else if(flag==0)
    			{
    				flag=a[0];
    				printf("%d%d%d%d",a[0],a[1],a[2],a[3]);
    			}
    			else 
    			{
    				flag=a[0];
    				printf("
    %d%d%d%d",a[0],a[1],a[2],a[3]);
    			}
    
    		}
    		cout<<endl;
    		f++;
    	}
    }

    看一下,这个函数每次执行的效果


     

  • 相关阅读:
    各种排序
    最大子数组的和与积
    字符串距离
    二叉树的基本操作
    C++11创建线程的几种方式
    二分查找
    汉诺塔问题
    读写锁实现
    全排列
    数字转汉字
  • 原文地址:https://www.cnblogs.com/unclejelly/p/4082106.html
Copyright © 2011-2022 走看看