zoukankan      html  css  js  c++  java
  • 洛谷 P3003 [USACO10DEC]苹果交货Apple Delivery

           洛谷 P3003 [USACO10DEC]苹果交货Apple Delivery

    题目描述

    Bessie has two crisp red apples to deliver to two of her friends in the herd. Of course, she travels the C (1 <= C <= 200,000)

    cowpaths which are arranged as the usual graph which connects P (1 <= P <= 100,000) pastures conveniently numbered from 1..P: no cowpath leads from a pasture to itself, cowpaths are bidirectional, each cowpath has an associated distance, and, best of all, it is always possible to get from any pasture to any other pasture. Each cowpath connects two differing pastures P1_i (1 <= P1_i <= P) and P2_i (1 <= P2_i <= P) with a distance between them of D_i. The sum of all the distances D_i does not exceed 2,000,000,000.

    What is the minimum total distance Bessie must travel to deliver both apples by starting at pasture PB (1 <= PB <= P) and visiting pastures PA1 (1 <= PA1 <= P) and PA2 (1 <= PA2 <= P) in any order. All three of these pastures are distinct, of course.

    Consider this map of bracketed pasture numbers and cowpaths with distances:

                   3        2       2
               [1]-----[2]------[3]-----[4]
                      /               /
                 7   /4  3           /2
                    /               /
                   [5]-----[6]------[7]
                        1       2

    If Bessie starts at pasture [5] and delivers apples to pastures [1] and [4], her best path is:

    5 -> 6-> 7 -> 4* -> 3 -> 2 -> 1*

    with a total distance of 12.

    贝西有两个又香又脆的红苹果要送给她的两个朋友。当然她可以走的C(1<=C<=200000)条“牛路”都被包含在一种常用的图中,包含了P(1<=P<=100000)个牧场,分别被标为1..P。没有“牛路”会从一个牧场又走回它自己。“牛路”是双向的,每条牛路都会被标上一个距离。最重要的是,每个牧场都可以通向另一个牧场。每条牛路都连接着两个不同的牧场P1_i和P2_i(1<=P1_i,p2_i<=P),距离为D_i。所有“牛路”的距离之和不大于2000000000。

    现在,贝西要从牧场PB开始给PA_1和PA_2牧场各送一个苹果(PA_1和PA_2顺序可以调换),那么最短的距离是多少呢?当然,PB、PA_1和PA_2各不相同。

    输入输出格式

    输入格式:

    * Line 1: Line 1 contains five space-separated integers: C, P, PB, PA1, and PA2

    * Lines 2..C+1: Line i+1 describes cowpath i by naming two pastures it connects and the distance between them: P1_i, P2_i, D_i

    输出格式:

    * Line 1: The shortest distance Bessie must travel to deliver both apples

    输入输出样例

    输入样例#1: 复制
    9 7 5 1 4 
    5 1 7 
    6 7 2 
    4 7 2 
    5 6 1 
    5 2 4 
    4 3 2 
    1 2 3 
    3 2 2 
    2 6 3 
    
    输出样例#1: 复制
    12 

    思路:SPFA + SLF 优化(以前从来没使过) 难度:提高+/省选- (自认为难度应该再低点)
    接下来讲一下我做这道题的(被坑)历程
    首先我看了看这道题 不就是跑两边SPFA吗,然后。。。
    #include<algorithm>
    #include<iostream>
    #include<cstring>
    #include<cstdio>
    #include<queue>
    #define M 200005
    #define MAXN 0x7fffffff
    using namespace std;
    queue<int> q;
    int m, n, s, t1, t2;
    int tot, minn;
    int dis[M], vis[M];
    int to[M*2], net[M*2], head[M*2], cap[M*2];
    
    void add(int u, int v, int w) {
        to[++tot] = v; net[tot] = head[u]; head[u] = tot; cap[tot] = w;
        to[++tot] = u; net[tot] = head[v]; head[v] = tot; cap[tot] = w;
    }
    
    void spfa(int x) {
        for(int i = 1; i <= n; i++) vis[i] = 0, dis[i] = MAXN;
        dis[x] = 0; vis[x] = 1; q.push(x);
        while(!q.empty()) {
            int y = q.front(); q.pop(); vis[y] = 0;
            for(int i = head[y]; i; i = net[i]) {
                int t = to[i];
                if(dis[t] > dis[y]+cap[i]) {
                    dis[t] = dis[y]+cap[i];
                    if(!vis[t]) vis[t] = 1, q.push(t);
                }
            }
        }
    }
    
    int main() {
        scanf("%d%d%d%d%d", &m, &n, &s, &t1, &t2);
        for(int i = 1; i <= m; i++) {
            int a, b, c;
            scanf("%d%d%d", &a, &b, &c);
            add(a, b, c);
        }
        spfa(t1);
        minn = dis[s] + dis[t2];
        spfa(t2);
        minn = min(minn, dis[s]+dis[t1]);
        printf("%d", minn);
        return 0;
    }
    裸的SPFA,RE了两个点

    居然RE了!我应该开的够大啊,然后数组多开了一个0,统统开long long,and then。。。

    #include<algorithm>
    #include<iostream>
    #include<cstring>
    #include<cstdio>
    #include<queue>
    #define LL long long
    #define M 2000005
    #define MAXN 0x7fffffff
    using namespace std;
    queue<LL> q;
    LL m, n, s, t1, t2;
    LL tot, minn;
    LL dis[M], vis[M];
    LL to[M*2], net[M*2], head[M*2], cap[M*2];
    
    void add(LL u, LL v, LL w) {
        to[++tot] = v; net[tot] = head[u]; head[u] = tot; cap[tot] = w;
        to[++tot] = u; net[tot] = head[v]; head[v] = tot; cap[tot] = w;
    }
    
    void spfa(LL x) {
        for(LL i = 1; i <= n; i++) vis[i] = 0, dis[i] = MAXN;
        dis[x] = 0; vis[x] = 1; q.push(x);
        while(!q.empty()) {
            int y = q.front(); q.pop(); vis[y] = 0;
            for(LL i = head[y]; i; i = net[i]) {
                LL t = to[i];
                if(dis[t] > dis[y]+cap[i]) {
                    dis[t] = dis[y]+cap[i];
                    if(!vis[t]) vis[t] = 1, q.push(t);
                }
            }
        }
    }
    
    int main() {
        scanf("%lld%lld%lld%lld%lld", &m, &n, &s, &t1, &t2);
        for(LL i = 1; i <= m; i++) {
            LL a, b, c;
            scanf("%lld%lld%lld", &a, &b, &c);
            add(a, b, c);
        }
        spfa(t1);
        minn = dis[s] + dis[t2];
        spfa(t2);
        minn = min(minn, dis[s]+dis[t1]);
        printf("%lld", minn);
        return 0;
    } 
    结果并没有什么卵用,继续RE两个点。。

    然后我明智(实在没办法)的问了学姐,结果她告诉我:“这个题我记得要用SLF优化” QAQ

    但是我不会啊

    然后学姐讲了加了SLF之后的变化,但是不知道为啥,我样例也过不了了 (大哭)

    通过比较发现,不开long long的时候结果还是对滴。。

    #include<algorithm>
    #include<iostream>
    #include<cstring>
    #include<cstdio>
    #include<deque>
    #define M 200005
    #define MAXN 0x7fffffff
    using namespace std;
    deque<int> q;
    int m, n, s, t1, t2;
    int tot, minn;
    int dis[M], vis[M];
    int to[M*2], net[M*2], head[M*2], cap[M*2];
    
    void add(int u, int v, int w) {
        to[++tot] = v; net[tot] = head[u]; head[u] = tot; cap[tot] = w;
        to[++tot] = u; net[tot] = head[v]; head[v] = tot; cap[tot] = w;
    }
    
    void spfa(int x) {
        for(int i = 1; i <= n; i++) vis[i] = 0, dis[i] = MAXN;
        dis[x] = 0; vis[x] = 1; q.push_back(x);
        while(!q.empty()) {
            int y = q.front(); q.pop_front(); vis[y] = 0;
            for(int i = head[y]; i; i = net[i]) {
                int t = to[i];
                if(dis[t] > dis[y]+cap[i]) {
                    dis[t] = dis[y]+cap[i];
                    if(!vis[t]) {
                        vis[t] = 1;
                        if(q.empty() || dis[t]<dis[q.front()]) q.push_front(t);
                        else q.push_back(t);
                    }
                }
            }
        }
    }
    
    int main() {
        scanf("%d%d%d%d%d", &m, &n, &s, &t1, &t2);
        for(int i = 1; i <= m; i++) {
            int a, b, c;
            scanf("%d%d%d", &a, &b, &c);
            add(a, b, c);
        }
        spfa(t1);
        minn = dis[s] + dis[t2];
        spfa(t2);
        minn = min(minn, dis[s]+dis[t1]);
        printf("%d", minn);
        return 0;
    }
    long long改回int,然后就A了。。

    内心一万头 * * * 奔过。。。。

    不过幸好最后还是A了

  • 相关阅读:
    OA系统配置文件
    OA系统配置文件
    OA系统配置文件
    OA系统配置文件
    如何在github上递交高质量的pull request
    如何在github上递交高质量的pull request
    如何在github上递交高质量的pull request
    如何在github上递交高质量的pull request
    Python 变量作用域
    python match search 和不匹配
  • 原文地址:https://www.cnblogs.com/v-vip/p/8688183.html
Copyright © 2011-2022 走看看