zoukankan      html  css  js  c++  java
  • Cisco PBR Case2

    如下图示:

    R1通过R4获取上游路由。
    R2通过R5获取上游路由。
    
    配置操作如下:
    R1:
    interface FastEthernet0/0
     ip address 13.1.1.1 255.255.255.0
    router ospf 1
     network 13.1.1.0 0.0.0.255 area 0
    
    R2:
    interface FastEthernet0/1
     ip address 23.1.1.2 255.255.255.0
    router ospf 1
     network 23.1.1.0 0.0.0.255 area 0
    
    R3:
    interface FastEthernet0/0
     ip address 13.1.1.3 255.255.255.0
     ip policy route-map r1
    interface FastEthernet0/1
     ip address 23.1.1.3 255.255.255.0
     ip policy route-map r2
    interface FastEthernet1/0
     ip address 34.1.1.3 255.255.255.0
    interface FastEthernet1/1
     ip address 35.1.1.3 255.255.255.0
    router ospf 1
     network 13.1.1.0 0.0.0.255 area 0
     network 23.1.1.0 0.0.0.255 area 0
     network 34.1.1.0 0.0.0.255 area 0
     network 35.1.1.0 0.0.0.255 area 0
    access-list 1 permit 13.1.1.0 0.0.0.255
    access-list 2 permit 23.1.1.0 0.0.0.255
    route-map r1 permit 10
     match ip address 1
     set ip precedence priority
     set ip next-hop 34.1.1.4
    route-map r2 permit 10
     match ip address 2
     set ip precedence critical
     set ip next-hop 35.1.1.5
    
    R4:
    interface FastEthernet0/0
     ip address 45.1.1.4 255.255.255.0
    interface FastEthernet0/1
     ip address 34.1.1.4 255.255.255.0
    router ospf 1
     network 34.1.1.0 0.0.0.255 area 0
     network 45.1.1.0 0.0.0.255 area 0
    
    R5:
    interface FastEthernet0/0
     ip address 45.1.1.5 255.255.255.0
    interface FastEthernet0/1
     ip address 35.1.1.5 255.255.255.0
    router ospf 1
     network 35.1.1.0 0.0.0.255 area 0
     network 45.1.1.0 0.0.0.255 area 0
    
    
    R1#traceroute 45.1.1.5
    
    Type escape sequence to abort.
    Tracing the route to 45.1.1.5
    
      1 13.1.1.3 28 msec 12 msec 12 msec
      2 34.1.1.4 32 msec 32 msec 48 msec
      3 45.1.1.5 44 msec 56 msec 48 msec
    
    R2#traceroute 45.1.1.4
    
    Type escape sequence to abort.
    Tracing the route to 45.1.1.4
    
      1 23.1.1.3 16 msec 12 msec 12 msec
      2 35.1.1.5 40 msec 36 msec 32 msec
      3 45.1.1.4 40 msec 32 msec 24 msec
  • 相关阅读:
    浅谈左偏树入门
    【洛谷3768】简单的数学题(莫比乌斯反演+杜教筛)
    【51nod1743】雪之国度(最小生成树+倍增)
    【BZOJ1562】[NOI2009] 变换序列(匈牙利算法)
    【HHHOJ】NOIP模拟赛 玖 解题报告
    【BZOJ3930】[CQOI2015] 选数(容斥)
    【BZOJ1257】[CQOI2007] 余数之和(除法分块)
    杜教筛入门
    初学狄利克雷卷积
    关于积性函数的一些知识
  • 原文地址:https://www.cnblogs.com/vincent-liang/p/6492078.html
Copyright © 2011-2022 走看看