zoukankan      html  css  js  c++  java
  • 思科BGP AS-PATH配置实例

    Cisco BGP AS-PATH配置实例如下图示:

    R1:
    interface Loopback0
     ip address 1.1.1.1 255.255.255.255
    interface FastEthernet0/0
     ip address 12.1.1.1 255.255.255.0
    interface FastEthernet0/1
     ip address 14.1.1.1 255.255.255.0
    router eigrp 1
     network 1.1.1.1 0.0.0.0
     network 12.1.1.0 0.0.0.255
     network 14.1.1.0 0.0.0.255
     no auto-summary
    router bgp 100
     bgp router-id 1.1.1.1
     bgp log-neighbor-changes
     no synchronization
     neighbor 2.2.2.2 remote-as 100
     neighbor 2.2.2.2 update-source Loopback0
     neighbor 2.2.2.2 next-hop-self
     neighbor 3.3.3.3 remote-as 100
     neighbor 3.3.3.3 update-source Loopback0
     neighbor 3.3.3.3 next-hop-self
     neighbor 4.4.4.4 remote-as 200
     neighbor 4.4.4.4 ebgp-multihop 255
     neighbor 4.4.4.4 update-source Loopback0
     neighbor 4.4.4.4 next-hop-self
     no auto-summary
    
    R2:
    interface Loopback0
     ip address 2.2.2.2 255.255.255.255
    interface FastEthernet0/0
     ip address 12.1.1.2 255.255.255.0
    interface FastEthernet0/1
     ip address 23.1.1.2 255.255.255.0
    router eigrp 1
     network 2.2.2.2 0.0.0.0
     network 12.1.1.0 0.0.0.255
     network 23.1.1.0 0.0.0.255
     no auto-summary
    router bgp 100
     no synchronization
     bgp router-id 2.2.2.2
     bgp log-neighbor-changes
     neighbor 1.1.1.1 remote-as 100
     neighbor 1.1.1.1 update-source Loopback0
     neighbor 1.1.1.1 next-hop-self
     neighbor 3.3.3.3 remote-as 100
     neighbor 3.3.3.3 update-source Loopback0
     neighbor 3.3.3.3 next-hop-self
     no auto-summary
    
    R3:
    interface Loopback0
     ip address 3.3.3.3 255.255.255.255
    interface FastEthernet0/0
     ip address 34.1.1.3 255.255.255.0
    interface FastEthernet0/1
     ip address 23.1.1.3 255.255.255.0
    router eigrp 1
     network 3.3.3.3 0.0.0.0
     network 23.1.1.0 0.0.0.255
     network 34.1.1.0 0.0.0.255
     no auto-summary
    router bgp 100
     no synchronization
     bgp router-id 3.3.3.3
     bgp log-neighbor-changes
     neighbor 1.1.1.1 remote-as 100
     neighbor 1.1.1.1 update-source Loopback0
     neighbor 1.1.1.1 next-hop-self
     neighbor 2.2.2.2 remote-as 100
     neighbor 2.2.2.2 update-source Loopback0
     neighbor 2.2.2.2 next-hop-self
     neighbor 4.4.4.4 remote-as 200
     neighbor 4.4.4.4 ebgp-multihop 255
     neighbor 4.4.4.4 update-source Loopback0
     neighbor 4.4.4.4 next-hop-self
     no auto-summary
    
    R4:
    interface Loopback0
     ip address 4.4.4.4 255.255.255.255
    interface FastEthernet0/0
     ip address 34.1.1.4 255.255.255.0
    interface FastEthernet0/1
     ip address 14.1.1.4 255.255.255.0
    router eigrp 1
     network 4.4.4.4 0.0.0.0
     network 14.1.1.0 0.0.0.255
     network 34.1.1.0 0.0.0.255
     no auto-summary
    ip prefix-list 1 seq 5 permit 4.4.4.4/32
    route-map as_path permit 10
     match ip address prefix-list 1
     set as-path prepend 600 700
    router bgp 200
     no synchronization
     bgp log-neighbor-changes
     neighbor 1.1.1.1 remote-as 100
     neighbor 1.1.1.1 ebgp-multihop 255
     neighbor 1.1.1.1 update-source Loopback0
     neighbor 1.1.1.1 next-hop-self
     neighbor 3.3.3.3 remote-as 100
     neighbor 3.3.3.3 ebgp-multihop 255
     neighbor 3.3.3.3 update-source Loopback0
     neighbor 3.3.3.3 next-hop-self
     neighbor 3.3.3.3 route-map as_path out
     no auto-summary
    
    
    
    
    R4(config-router)#do ping 1.1.1.1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/36/40 ms
    R4(config-router)#do traceroute 1.1.1.1
    
    Type escape sequence to abort.
    Tracing the route to 1.1.1.1
    
      1 34.1.1.3 8 msec 12 msec 24 msec
      2 23.1.1.2 32 msec 36 msec 44 msec
      3 12.1.1.1 32 msec 44 msec 32 msec
    R4(config-router)#
    R4(config-router)#do show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route
    
    Gateway of last resort is not set
    
         34.0.0.0/24 is subnetted, 1 subnets
    C       34.1.1.0 is directly connected, FastEthernet0/0
         1.0.0.0/32 is subnetted, 1 subnets
    D       1.1.1.1 [90/460800] via 34.1.1.3, 00:05:23, FastEthernet0/0
         2.0.0.0/32 is subnetted, 1 subnets
    D       2.2.2.2 [90/435200] via 34.1.1.3, 00:03:07, FastEthernet0/0
         3.0.0.0/32 is subnetted, 1 subnets
    D       3.3.3.3 [90/409600] via 34.1.1.3, 00:05:25, FastEthernet0/0
         4.0.0.0/32 is subnetted, 1 subnets
    C       4.4.4.4 is directly connected, Loopback0
         23.0.0.0/24 is subnetted, 1 subnets
    D       23.1.1.0 [90/307200] via 34.1.1.3, 00:05:36, FastEthernet0/0
         12.0.0.0/24 is subnetted, 1 subnets
    D       12.1.1.0 [90/332800] via 34.1.1.3, 00:03:10, FastEthernet0/0
         14.0.0.0/24 is subnetted, 1 subnets
    D       14.1.1.0 [90/358400] via 34.1.1.3, 00:05:37, FastEthernet0/0
  • 相关阅读:
    nodeJS中的包
    NPM
    代码检查工具jshint和csslint
    javascript中Date对象的应用
    Collection包结构,与Collections的区别
    TreeMap、HashMap、LindedHashMap的区别
    HashMap和ConcurrentHashMap的区别,HashMap的底层源码
    HashMap和HashTable的区别
    Map、Set、List、Queue、Stack的特点与用法
    String、StringBuffer与StringBuilder的区别
  • 原文地址:https://www.cnblogs.com/vincent-liang/p/6517587.html
Copyright © 2011-2022 走看看