zoukankan      html  css  js  c++  java
  • [2011山东ACM省赛] Identifiers(模拟)

    Identifiers

    Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

    题目描述

     Identifier is an important concept in the C programming language. Identifiers provide names for several language elements, such as functions, variables, labels, etc.

    An identifier is a sequence of characters. A valid identifier can contain only upper and lower case alphabetic characters, underscore and digits, and must begin with an alphabetic character or an underscore. Given a list of chararcter sequences, write a program to check if they are valid identifiers.

    输入

     The first line of the input contains one integer, N, indicating the number of strings in the input. N lines follow, each of which contains at least one and no more than 100 characters. (only upper and lower case alphabetic characters, digits, underscore (" "), hyphen ("-"), period ("."), comma (","), colon (":"), semicolon (";"), exclamation mark ("!"), question mark ("?"), single and double quotation marks, parentheses, white space and square brackets may appear in the character sequences.)

    输出

    For each of the N lines, output "Yes" (without quote marks) if the character sequence contained in that line make a valid identifier; output "No" (without quote marks) otherwise.

    示例输入

    7
    ValidIdentifier
    valid_identifier
    valid_identifier
    0 invalid identifier
    1234567
    invalid identifier
    adefhklmruvwxyz12356790 -.,:;!?'"()[]ABCDGIJLMQRSTVWXYZ

    示例输出

    Yes
    Yes
    Yes
    No
    No
    No
    No

    提示

     

    来源

    山东省第二届ACM大学生程序设计竞赛

    解题思路:

    判断是否输入的字符串为合法标识符。

    代码:

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <ctype.h>
    using namespace std;
    string str[1000];
    int main()
    {
        int n;cin>>n;
        getchar();//必须得加这个,吸收空格,否则后面用getline会出错
        for(int i=1;i<=n;i++)
        {
            getline(cin,str[i]);
            bool ok=1;
            int len=str[i].length();
            if(!isalpha(str[i][0])&&str[i][0]!='_')//首字母不是字母也不是下划线
            {
                cout<<"No"<<endl;
                continue;
            }
            for(int j=0;j<len;j++)
            {
                if(!isdigit(str[i][j])&&!isalpha(str[i][j])&&str[i][j]!='_')//不符合要求
                {
                    ok=0;
                    break;
                }
            }
            if(ok)
                cout<<"Yes"<<endl;
            else
                cout<<"No"<<endl;
        }
        return 0;
    }
    


     

  • 相关阅读:
    推荐阅读20100603
    [ASP.NET4之旅]Circular file references are not allowed
    满园尽是503,记曾经的一次IIS 7性能考验
    VS2010小Bug:找不到System.Web.Extensions.dll引用
    VS2010奇异Bug:三个中文符号在CSS文件中轻松让VS2010崩溃
    推荐阅读20100528
    Windows平台网站文件同步备份解决方案——cwRsyn
    推荐阅读20100803
    在IE8中使用建行企业网银的解决方法
    博客园已经用上NorthScale Memcached Server
  • 原文地址:https://www.cnblogs.com/vivider/p/3697642.html
Copyright © 2011-2022 走看看