zoukankan      html  css  js  c++  java
  • 1081 检查密码 (15 分)

    本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。

    输入格式:

    输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。

    输出格式:

    对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

    • 如果密码合法,输出Your password is wan mei.
    • 如果密码太短,不论合法与否,都输出Your password is tai duan le.
    • 如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.
    • 如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.
    • 如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.

    输入样例:

    5
    123s
    zheshi.wodepw
    1234.5678
    WanMei23333
    pass*word.6
    

    输出样例:

    Your password is tai duan le.
    Your password needs shu zi.
    Your password needs zi mu.
    Your password is wan mei.
    Your password is tai luan le.
    #include<iostream>
    using namespace std;
    const int maxn = 110;
    
    int main(){
        int n;
        cin >> n;
        string s;
        getchar();
        while(n--){
            getline(cin,s);
            //cin >> s;
            bool tag[4] = {false};
            if(s.length() < 6){
                cout << "Your password is tai duan le." << endl;
                continue;
            }
            for(int i = 0; i < s.length(); i++){
                if(s[i] >= '0' && s[i] <= '9')
                     tag[0] = true;
                else if((s[i] >= 'a' && s[i] <= 'z')||(s[i] >= 'A' && s[i] <= 'Z')) tag[1] = true;
                else if(s[i] == '.') tag[2] = true;
                else tag[3] = true;
            }
            if(tag[3]) cout <<"Your password is tai luan le." << endl;
            //tag[0] == 1表示有数字,tag[1]  == 1表示有字母 
            else if(tag[1] == false) cout <<"Your password needs zi mu." << endl;
            else if(tag[0] == false)cout << "Your password needs shu zi." << endl;
            else cout <<"Your password is wan mei." << endl;
            for(int i = 0 ; i < 4; i++) tag[i] = false;
        }
        return 0;
    }
  • 相关阅读:
    转--Android中自定义字体的实现方法
    android中Intent传值与Bundle传值的区别详解
    通过Application传递数据代码
    LayoutInflater的使用
    转--Android资源总结(环境搭建/ 反编译工具)
    转--android Toast大全(五种情形)建立属于你自己的Toast
    转--9中对话框
    转--全局异常处理
    安卓记住密码
    转--Android学习笔记-实用代码合集
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/10427471.html
Copyright © 2011-2022 走看看