zoukankan      html  css  js  c++  java
  • 1136 A Delayed Palindrome (20 分)

    Consider a positive integer N written in standard notation with k+1 digits ai​​ as ak​​a1​​a0​​ with 0 for all i and ak​​>0. Then N is palindromic if and only if ai​​=aki​​ for all i. Zero is written 0 and is also palindromic by definition.

    Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

    Given any positive integer, you are supposed to find its paired palindromic number.

    Input Specification:

    Each input file contains one test case which gives a positive integer no more than 1000 digits.

    Output Specification:

    For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

    A + B = C
    

    where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number -- in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

    Sample Input 1:

    97152
    

    Sample Output 1:

    97152 + 25179 = 122331
    122331 + 133221 = 255552
    255552 is a palindromic number.
    

    Sample Input 2:

    196
    

    Sample Output 2:

    196 + 691 = 887
    887 + 788 = 1675
    1675 + 5761 = 7436
    7436 + 6347 = 13783
    13783 + 38731 = 52514
    52514 + 41525 = 94039
    94039 + 93049 = 187088
    187088 + 880781 = 1067869
    1067869 + 9687601 = 10755470
    10755470 + 07455701 = 18211171
    Not found in 10 iterations.
    #include<iostream>
    #include<algorithm>
    using namespace std;
    
    bool isPalindromic(string &str){
        int len = str.size();
        for(int i = 0; i < len/2; i++){
            if(str[i] != str[len - i - 1]) 
                return false;
        }
        return true;
    }
    
    string add(const string &A,const string &B){
        string C;
        int len = A.size();
        int carry = 0;
        for(int i = len - 1; i >= 0; i--){
            int temp = A[i] - '0' + B[i] - '0' + carry;
            C += temp % 10 +'0';
            carry = temp / 10;
        }
        if(carry != 0) C += carry + '0';
        reverse(C.begin(),C.end());
        return C;
    }
    
    int main(){
        string A,B,C;
        cin >> A;
        int cnt = 10;
        if(isPalindromic(A)){
                 cout << A << " is a palindromic number.";
                 return 0;
            }
        while(cnt--){
            B = A;
            reverse(A.begin(),A.end());
            C = add(A,B);
            cout << B << " + " << A << " = " << C << endl;
            if(isPalindromic(C)){
                 cout << C << " is a palindromic number.";
                 return 0;
            }
            A = C;
        }
        cout <<"Not found in 10 iterations.";
        return 0;
    } 
  • 相关阅读:
    java 获取json字符串中key对应的值
    location.href跳转页面时传递参数并且在新页面接收参数
    bootstrap table 合并列(只合并相邻的相同项)
    谷歌浏览器输入框清除历史输入记录
    js高德地图支持,java获取高德地图两点间的距离
    ASP.NET Excel 文件导入与导出实例
    Struts2入门---输入验证---验证身份证案例
    Struts2入门---国际化
    Struts2入门---消息处理和类型转换
    Struts2入门---增删改查- 拦截器栈的应用
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/10453492.html
Copyright © 2011-2022 走看看