zoukankan      html  css  js  c++  java
  • 06-图2 Saving James Bond

    This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape -- he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head... Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

    Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

    Input Specification:

    Each input file contains one test case. Each case starts with a line containing two positive integers N (≤), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the ( location of a crocodile. Note that no two crocodiles are staying at the same position.

    Output Specification:

    For each test case, print in a line "Yes" if James can escape, or "No" if not.

    Sample Input 1:

    14 20
    25 -15
    -25 28
    8 49
    29 15
    -35 -2
    5 28
    27 -29
    -8 -28
    -20 -35
    -25 -20
    -13 29
    -30 15
    -35 40
    12 12
    

    Sample Output 1:

    Yes
    

    Sample Input 2:

    4 13
    -12 12
    12 12
    -12 -12
    12 -12
    

    Sample Output 2:

    No
    #include<cstdio>
    #include<cmath>
    #include<cstdlib>
    
    const int maxn = 110;
    const double ISLAND_RADIUS = 15.0/2;
    const double SQUARE_SIZE = 100.0;
    
    typedef struct Point{
        double x,y;
    }Position;
    
    Position P[maxn];
    int n;
    double d;
    bool isVis[maxn] = {false};
    
    void Save007();
    bool FirstJump(int v);
    bool DFS(int v);
    bool Jump(int v1,int v2);
    bool Judge(int v);
    
    int main(){
        scanf("%d%lf",&n,&d);
        for(int i = 0; i < n; i++){
            scanf("%lf%lf",&P[i].x,&P[i].y);
        }
        
        Save007();
        return 0;
    }
    
    void Save007(){
        bool isSave = false;
        for(int i = 0; i < n; i++){
            if(!isVis[i] && FirstJump(i)){
                isSave = DFS(i);
                if(isSave) break;
            }
        }
        if(isSave) printf("Yes");
        else printf("No");
    }
    
    bool FirstJump(int v){
        double x = pow(P[v].x,2);
        double y = pow(P[v].y,2);
        double dis = sqrt(x+y);
        return dis <= d + ISLAND_RADIUS;
    }
    
    bool DFS(int v){
        bool answer = false;
         isVis[v] = true;
        if(Judge(v)) return true;
        for(int i = 0; i < n; i++){
            if(!isVis[i] && Jump(v,i)){
                answer = DFS(i);            
            }
            if(answer) break;
        }
        if(answer) return true;
        else return false;
    }
    
    bool Jump(int v1,int v2){
        int x = P[v1].x - P[v2].x;
        int y = P[v1].y - P[v2].y;
        double dis = sqrt(pow(x,2) + pow(y,2));
        return dis <= d;
    }
    
    bool Judge(int v){
        return (abs(P[v].x) >= 50 - d || abs(P[v].y) >= 50 -d);
    }
  • 相关阅读:
    Day10 作业
    深浅拷贝
    列表,字符串,字典,元组,集合内置方法
    Notification操作大全
    Recyclerview 顶部悬停 stick
    扩展AutoCompleteTextView让其默认显示一组列表。setThreshold
    获得了Root权限后Read-only file system
    Called attach on a child which is not detached
    CollapsingToolbarLayout Toolbar的title覆盖问题
    【转】Material Design 折叠效果 Toolbar CollapsingToolbarLayout AppBarLayout
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/10792319.html
Copyright © 2011-2022 走看看