zoukankan      html  css  js  c++  java
  • 11-散列2 Hashing (25 分)

    The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be ( where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

    Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤) and N (≤) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

    Sample Input:

    4 4
    10 6 4 15
    

    Sample Output:

    0 1 4 -
    #include<cstdio>
    #include<cmath>
    const int maxn = 10010;
    
    bool isPrime(int x){
        if(x <= 1) return false;
        int sqr = (int)sqrt(1.0*x);
        for(int i = 2; i <= sqr; i++){
            if(x % i == 0) return false;
        }
        return true;
    }
    
    bool HashTable[maxn] = {0};
    int main(){
        int Msize,n,a;
        scanf("%d%d",&Msize,&n);
        while(isPrime(Msize) == false) Msize++;
        for(int i = 0; i < n; i++){
            scanf("%d",&a);
            int m = a % Msize;
            if(HashTable[m] == false){
                HashTable[m] = true;
                if(i == 0) printf("%d",m);
                else printf(" %d",m);
            }else{
                int step;
                for(step = 1; step <= Msize; step++){
                    int m = (a+step*step)%Msize;
                    if(HashTable[m] == false){
                        HashTable[m] = true;
                        if(i == 0) printf("%d",m);
                        else printf(" %d",m);
                        break;
                    }
                }
                if(step >= Msize){
                    if(i > 0)printf(" ");
                    printf("-");
                    
                }
            }
        }
        return 0;
    }
  • 相关阅读:
    个人案例分析
    软工结对作业
    交点问题
    C语言复习
    【软件工程】提问回顾与个人总结
    【技术博客】Arxiv的新Paper获取和机翻
    【技术博客】动态面包屑导航
    对对碰 -- 软工结对编程博客
    交点计数 -- 软工个人项目作业
    面向对象的程序设计-模块四课程总结
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/10946259.html
Copyright © 2011-2022 走看看