zoukankan      html  css  js  c++  java
  • 01-复杂度2 Maximum Subsequence Sum (25 分)

    Given a sequence of K integers { N1​​, N2​​, ..., NK​​ }. A continuous subsequence is defined to be { Ni​​, Ni+1​​, ..., Nj​​ } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

    Input Specification:

    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤). The second line contains K numbers, separated by a space.

    Output Specification:

    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    Sample Input:

    10
    -10 1 2 3 4 -5 -23 3 7 -21
    

    Sample Output:

    10 1 4
    #include<cstdio>
    const int maxn = 100100;
    
    int main()
    {
        int a[maxn];
        int dp[maxn];
        int s[maxn];
        
        int n;
        bool flag = false;
        scanf("%d",&n);
        for ( int i = 0; i < n; i++ )
        {
            scanf("%d",&a[i]);
            if ( !flag && ( a[i] >= 0 ) )
            {
                flag = true;
            }
        }
        
        if ( !flag )
        {
            printf("0 %d %d",a[0],a[n-1]);
        }
        else
        {
            dp[0] = a[0];
            s[0] = 0;
            for ( int i = 1; i < n; i++ )
            {
                if ( dp[i - 1] + a[i] >= a[i] )
                {
                    dp[i] = dp[i - 1] + a[i];
                    s[i] = s[i - 1];
                }
                else
                {
                    dp[i] = a[i];
                    s[i] = i;
                }
            }
            
            int k = -1;
            int max = -1;
            for ( int i = 0; i < n; i++)
            {
                if ( dp[i] > max)
                {
                    max = dp[i];
                    k = i;
                }
            }
            
            printf("%d %d %d",max,a[s[k]],a[k]);
        }
        return 0;
    }
  • 相关阅读:
    VSCode拓展插件推荐(HTML、Node、Vue、React开发均适用)
    算法_栈的Java的通用数组实现
    算法_计算输入的算术表达式的值.
    设计模式整理_组合模式
    JavaSE复习_9 集合框架复习
    一个小题目的三种不同的解法
    设计模式整理_状态模式
    设计模式整理_迭代器模式
    设计模式整理_模板模式
    JavaSE复习_8 泛型程序设计
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/11688678.html
Copyright © 2011-2022 走看看