zoukankan      html  css  js  c++  java
  • 1073. Scientific Notation (20)

    Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9]"."[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent's signs are always provided even when they are positive.

    Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

    Input Specification:

    Each input file contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent's absolute value is no more than 9999.

    Output Specification:

    For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros,

    Sample Input 1:

    +1.23400E-03
    

    Sample Output 1:

    0.00123400
    

    Sample Input 2:

    -1.2E+10
    

    Sample Output 2:

    -12000000000
    #include<cstdio>
    #include<cstring>
    
    int main(){
        char str[11000];
        gets(str);
        int pos = 0, len = strlen(str);
        int i;
        if(str[0] == '-') printf("-");
        while(str[pos] != 'E'){  //找到E的位置 
            pos++;
        }
        int exp = 0;
        for(i = pos + 2; i < len; i++){ //求出指数 
            exp = exp * 10 + (str[i] - '0');
        }
        if(exp == 0){
            for(i = 1; i < pos; i++){   //特判指数为零时,直接输出 
                printf("%c",str[i]);    
            }
        }
        if(str[pos + 1] == '-') { //如果指数为负 
            printf("0.");
            for(i = 0; i < exp - 1; i++){
                printf("0");
            }
            printf("%c",str[1]);
            for(i = 3; i < pos; i++){
                printf("%c",str[i]);
            }
        }else{
            for(i = 1; i < pos; i++){
                
                if(str[i] == '.') continue;
                printf("%c",str[i]);
                if(i == exp + 2 && exp !=  pos - 3){ //pos-3代表这个数字有效部分长度,exp表示指数。如果指数大于pos-3,意味着不用输出小数点。
                    printf(".");
                }
            }
            for(i = 0; i < exp - (pos - 3); i++){
                printf("0");
            }
        } 
        
        return 0;
    }
  • 相关阅读:
    lnmp 优化
    linux-lnmp 搭建报错
    nfs 配置
    全网备份脚本rsync
    .Net面试题二
    软件设计模式
    .Net面试题一
    asp.net运行机制
    NHiberante的优缺点
    什么是架构、框架、模式和平台
  • 原文地址:https://www.cnblogs.com/wanghao-boke/p/8545828.html
Copyright © 2011-2022 走看看