zoukankan      html  css  js  c++  java
  • codes often WA

    枚举:

    1.完美立方

    #include<iostream>

    #include <cstdio>

    using namespace std;

    int main()

    {

    int N;

    scanf("%d",&N);

    for (int a = 2; a <= N; ++a)
    for(int b = 2;b< a;++b)
    for(int c = b;c < a;++c)
    for(int d = c;d < a;++d)
    if(a * a * a == b *b *b + c*c*c+d*d*d)
    printf("Cube = %d,Triple =(%d,%d,%d) ",a,b,c,d);

    return 0;

    }

    2.

    生理周期

    原题如下:

    Biorhythms
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 110700   Accepted: 34443

    Description

    Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier. 
    Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak. 

    Input

    You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.

    Output

    For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form: 

    Case 1: the next triple peak occurs in 1234 days. 

    Use the plural form ``days'' even if the answer is 1.

    Sample Input

    0 0 0 0
    0 0 0 100
    5 20 34 325
    4 5 6 7
    283 102 23 320
    203 301 203 40
    -1 -1 -1 -1

    Sample Output

    Case 1: the next triple peak occurs in 21252 days.
    Case 2: the next triple peak occurs in 21152 days.
    Case 3: the next triple peak occurs in 19575 days.
    Case 4: the next triple peak occurs in 16994 days.
    Case 5: the next triple peak occurs in 8910 days.
    Case 6: the next triple peak occurs in 10789 days.

    Source

     
     

    #include <iostream>
    #include<cstdio>
    using namespace std;
    #define N 21252;
    int main()
    {
    int p,e,i,k,d,caseNO = 0;
    while(cin >>p>> e>>i >>d && p != -1)
    {
    ++caseNO;

    for(k = d+1 ;(k-p)%23;++k);
    for(;(k-e)%28; k+= 23);
    for (;(k-i)%33;k+=23*28);
    cout << "caseNO" << ": the next triple peak occurs in " << k-d<<endl;

    }

    return 0;
    }

    3.称硬币

    #include <iostream>
    #include <cstring>
    using namespace std;
    char Left[3][7];
    char Right[3][7];
    char result[3][7];
    bool isFake(char c,bool light);

    int main()
    {
    int t;
    cin >> t;
    while(t--)
    {
    for(int i = 0; i < 3; i++)
    cin >> Left[i] >> Right[i] >> result[i];
    for(char c = 'A';c <= 'L';c++)
    {
    if(isFake(c,true))
    {
    cout << c << "is the counterfeit coin and it is light. ";
    break;
    }
    else if (isFake(c,false))
    {
    cout << c << "is the counterfeit coin and it is heavy. ";
    break;

    }
    }
    }

    return 0;
    }
    bool isFake(char c,bool light)
    {
    for (int i=1;i<=3;i++)
    resul
    if ()
    return true;
    else
    return false;
    }

     

     4,熄灯问题

    #include<memory>
    #include<string>
    #include<cstring>
    #include <iostream>
    using namespace std;
    char oriLights[5];
    char lights[5];
    char result[5];

    int GetBit(char c,int i)
    {
    return (c >> i) & 1;
    }

    void SetBit(char & c, int i ,int v)//c 的第i位变位v
    {
    if(v == 1){
    c |= ( 1 << i);//c 或 后移i个位置
    }
    else // v == 0
    c &= ~(1 << i); //c的第i位为1 ; 取反(第i位成0);与(第i位成0)
    }
    void FlipBit(char &c, int i)
    {
    c ^= ( 1 << i);
    }


    void OutPutResult(int t,char result[])
    {
    cout
    }

    ---------------------------------------分隔符------------------------------------------------------------------- 

    while(~scanf("%d%d",&m,&n))等同于while (scanf("%d%d",&m,&n)!=EOF)

     ---------------------------------------分隔符------------------------------------------------------------------- 

     

    #include <stdio.h>

    #define maxsize 32575

    typedef int SElemType;

    typedef struct stack{

    SElemType *base,*top;

    int stacksize;

    }stack;

     

    int Initstack(stack &S){  &s  S    *S  &S 

    S.base = new SElemType[maxsize];

    if(!S.base)

    return -1;

    S.base = S.top;

    S.stacksize = maxsize;

    return 0;

    }

    int push(stack &S,SElemType e){

    if(S.top -S.base == S.stacksize)

    return -1;

    *(S.top++) = e;

    return e;

    }

     

    int pop(stack &S,SElemType &e){

    if(S.top == S.base)

    return -1;

    e = *--S.top;

    return 1;

    }

     

    int stackEmpty(stack S){

    if(S.base == S.top)

    return -1;

    return 0;

    }

    //十进制转换为八进制

     

    int main(int a){

        stack S;

        SElemType e;

    Initstack(S);

    stackEmpty(S);

    scanf("%d",&a);

    while(a){

    push(S,a%8);

    a = a/8;

    }

    while(!stackEmpty(S)){

    pop(S,e);

    printf("%d",e);

    }

     

    return 0;

    }

     

     ---------------------------------------分隔符------------------------------------------------------------------- 

    沙耶加是最棒的也是最强的,今天换我来拯救世界!
  • 相关阅读:
    深度学习与Pytorch入门实战(二)Pytorch张量高阶操作
    深度学习与Pytorch入门实战(一)Pytorch张量操作
    【邱希鹏】nndl-chap2-linear_regression
    【邱希鹏】nndl-chap1-warmup
    【Deeplearning.ai 】吴恩达深度学习笔记及课后作业目录
    Sequence Model-week3编程题2-Trigger Word Detection
    Sequence Model-week3编程题1-Neural Machine Translation with Attention
    Coursera Deep Learning笔记 序列模型(三)Sequence models & Attention mechanism(序列模型和注意力机制)
    LSTM的参数return_sequences含义
    conda离线安装
  • 原文地址:https://www.cnblogs.com/wanghui626/p/6126333.html
Copyright © 2011-2022 走看看