zoukankan      html  css  js  c++  java
  • hdu 1312 Red and Black

    Problem Description
    There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

    Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
     
    Input
    The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

    There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

    '.' - a black tile 
    '#' - a red tile 
    '@' - a man on a black tile(appears exactly once in a data set) 
     
    Output
    For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
     
    Sample Input
    6 9
    ....#.
    .....#
    ......
    ......
    ......
    ......
    ......
    #@...#
    .#..#.
    11 9
    .#.........
    .#.#######.
    .#.#.....#. .#.
    #.###.#. .#.
    #..@#.#. .#.
    #####.#.
    .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
     
    Sample Output
    45
    59
    6
    13
    #include<iostream>
    using namespace std;
    char mapp[65][65];
    int m,n,k=0,c=0,d=0;
    void dfs(int x,int y)
    {
        if(mapp[x][y]=='#'||x<0||y<0||x>=m||y>=n)
        {
            return;
        } 
        mapp[x][y]='#';
        dfs(x+1,y);
        dfs(x-1,y);
        dfs(x,y+1);
        dfs(x,y-1);
    }
    int main()
    {
        int i,j,k; 
        while(cin>>n>>m)
        {
            c=0;
            d=0;
            if(m==0&&n==0)
            break;
            for(i=0;i<m;i++)
            {
                for(j=0;j<n;j++)
                {
                    cin>>mapp[i][j];
                }    
            }
            for(i=0;i<m;i++)
            for(j=0;j<n;j++)
            {
                if(mapp[i][j]=='#')
                c++;
            }
            k=0;
            for(i=0;i<m;i++)
            {
                    for(j=0;j<n;j++)
                {
                    if(mapp[i][j]=='@')
                    {
                        mapp[i][j]='.';
                        dfs(i,j);
                    }
                }
            }
            for(i=0;i<m;i++)
            for(j=0;j<n;j++)
            {
                if(mapp[i][j]=='#')
                d++;
            }
            cout<<d-c<<endl;
        }
        return 0;
    }
  • 相关阅读:
    python 连接ubuntu xampp mysql
    [解决] win7能上网,ubuntu14.04不行
    ubuntu14.04 安装 pyv8
    QT_QMAKE_EXECUTABLE reported QT_INSTALL_LIBS as /usr/lib/i386-linux-gnu but ...
    网站运营思想
    织梦直接往数据库写入数据
    [xunsearch] 在thinkphp中使用xunsearch
    [xampp] phpmyadmin 设置登录密码
    [centos6.5] 把xampp的htdocs改为其他目录
    [ubuntu] service apache2 restart [fail]
  • 原文地址:https://www.cnblogs.com/wangmenghan/p/5399372.html
Copyright © 2011-2022 走看看