zoukankan      html  css  js  c++  java
  • HDOJ(HDU) 2309 ICPC Score Totalizer Software(求平均值)

    Problem Description
    The International Clown and Pierrot Competition (ICPC), is one of the most distinguished and also the most popular events on earth in the show business.
    One of the unique features of this contest is the great number of judges that sometimes counts up to one hundred. The number of judges may differ from one contestant to another, because judges with any relationship whatsoever with a specific contestant are temporarily excluded for scoring his/her performance.

    Basically, scores given to a contestant’s performance by the judges are averaged to decide his/her score. To avoid letting judges with eccentric viewpoints too much influence the score, the highest and the lowest scores are set aside in this calculation. If the same highest score is marked by two or more judges, only one of them is ignored. The same is with the lowest score. The average, which may contain fractions, are truncated down to obtain final score as an integer.

    You are asked to write a program that computes the scores of performances, given the scores of all the judges, to speed up the event to be suited for a TV program.

    Input
    The input consists of a number of datasets, each corresponding to a contestant’s performance. There are no more than 20 datasets in the input.

    A dataset begins with a line with an integer n, the number of judges participated in scoring the performance (3 ≤ n ≤ 100). Each of the n lines following it has an integral score s (0 ≤ s ≤ 1000) marked by a judge. No other characters except for digits to express these numbers are in the input. Judges’ names are kept secret.

    The end of the input is indicated by a line with a single zero in it.

    Output
    For each dataset, a line containing a single decimal integer indicating the score for the corresponding performance should be output. No other characters should be on the output line.

    Sample Input
    3
    1000
    342
    0
    5
    2
    2
    9
    11
    932
    5
    300
    1000
    0
    200
    400
    8
    353
    242
    402
    274
    283
    132
    402
    523
    0

    Sample Output
    342
    7
    300
    326

    分数都是整数!平均分也要是整数!
    评委打分,去掉一个最高分,去掉一个最低分,求剩下的平均分!
    不用四舍五入。直接舍去小数位就可以。

    import java.util.Scanner;
    
    public class Main{
    
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            while(sc.hasNext()){
                int n=sc.nextInt();
                if(n<=0){
                    return ;
                }
                int sum =0;
                int min = sc.nextInt();
                int max=min;
                sum=max;
                int b;
                for(int i=1;i<n;i++){
                    b = sc.nextInt();
                    if(b>max){
                        max=b;
                    }
                    if(b<min){
                        min=b;
                    }
                    sum+=b;
                }
                sum=sum-min-max;
                System.out.println((int)(sum/(n-2)));
            }
        }
    }
    
  • 相关阅读:
    (转)移动端实现垂直居中的几种方法
    FloatingActionButton 完全解析
    android 开源编辑器
    如何使用PullToRefresh
    Android 使用代码主动去调用控件的点击事件(模拟人手去触摸控件)
    Gradle 下载
    android studio 中移除module和恢复module
    android studio 使用jar包,arr包和怎么使用githup开源项目中的aar包或module
    DrawerLayout 和 NavigationView 的使用
    android studio 集成微信登录
  • 原文地址:https://www.cnblogs.com/webmen/p/5739208.html
Copyright © 2011-2022 走看看