zoukankan      html  css  js  c++  java
  • HDOJ(HDU) 2161 Primes(素数打表)

    Problem Description
    Write a program to read in a list of integers and determine whether or not each number is prime. A number, n, is prime if its only divisors are 1 and n. For this problem, the numbers 1 and 2 are not considered primes.

    Input
    Each input line contains a single integer. The list of integers is terminated with a number<= 0. You may assume that the input contains at most 250 numbers and each number is less than or equal to 16000.

    Output
    The output should consists of one line for every number, where each line first lists the problem number, followed by a colon and space, followed by “yes” or “no”.

    Sample Input
    1
    2
    3
    4
    5
    17
    0

    Sample Output
    1: no
    2: no
    3: yes
    4: no
    5: yes
    6: yes

    给你一个数,判断它是不是素数,是素数输出**: yes,不是就输出
    **: no
    注意:1和2要输出no。
    还有,判断结束的标志是n<=0.

    import java.util.Arrays;
    import java.util.Scanner;
    
    public class Main{
        static boolean db[] = new boolean[16001];
        public static void main(String[] args) {
            prime();
            Scanner sc = new Scanner(System.in);
            int t=0;
            while(sc.hasNext()){
                int n =sc.nextInt();
                if(n<=0){
                    break;
                }
                if(db[n]){
                    System.out.println((++t)+": yes");
                }else{
                    System.out.println((++t)+": no");
                }
            }
        }
        private static void prime() {
            Arrays.fill(db, true);
            db[1]=false;
            db[2]=false;
            for(int i=2;i<=Math.sqrt(db.length);i++){
                for(int j=i+i;j<db.length;j+=i){
                    if(db[j]){
                        db[j]=false;
                    }
                }
            }
        }
    }
    
  • 相关阅读:
    构造方法
    封装 private
    局部变量和成员变量区别
    IOC
    Linux端口占用查询命令
    Nginx小白入门实战
    SQL left join right join inner join之间的区别
    IDEA导入maven工程时,不会自动识别怎么办
    Spring中Controller层中的method显示为灰色并且提示method is never used的原因
    查看服务器公网IP
  • 原文地址:https://www.cnblogs.com/webmen/p/5739221.html
Copyright © 2011-2022 走看看