zoukankan      html  css  js  c++  java
  • HDOJ(HDU) 1570 A C

    Problem Description
    Are you excited when you see the title “AC” ? If the answer is YES , AC it ;

    You must learn these two combination formulas in the school . If you have forgotten it , see the picture.

    Now I will give you n and m , and your task is to calculate the answer .

    Input
    In the first line , there is a integer T indicates the number of test cases.
    Then T cases follows in the T lines.
    Each case contains a character ‘A’ or ‘C’, two integers represent n and m. (1<=n,m<=10)

    Output
    For each case , if the character is ‘A’ , calculate A(m,n),and if the character is ‘C’ , calculate C(m,n).
    And print the answer in a single line.

    Sample Input
    2
    A 10 10
    C 4 2

    Sample Output
    3628800
    6

    题意:很简单,看图片就能理解了。
    水题一个!就不多解释了。

    import java.util.Scanner;
    
    public class Main{
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            int t = sc.nextInt();
            while(t-->0){
                String str = sc.next();
                int n = sc.nextInt();
                int m =sc.nextInt();
    
                if(str.charAt(0)=='A'){
                    System.out.println(a(n,m));
                }else{
                    System.out.println(c(n,m));
                }
    
            }
    
        }
    
        private static int c(int n, int m) {
            int num =1;
            if(n-m>m){
                m=n-m;
            }
            int cnum=1;
            for(int i=1;i<=n-m;i++){
                cnum=cnum*i;
            }
            for(int i=m+1;i<=n;i++){
                num=num*i;
            }
            return num/cnum;
        }
    
        private static int a(int n, int m) {
            int num=1;
            for(int i=n-m+1;i<=n;i++){
                num=num*i;
            }
            return num;
        }
    }
    
  • 相关阅读:
    netty(七)buffer源码学习2
    netty(六) buffer 源码分析
    netty(五) channel
    netty(三)---NioEventLoop分析
    netty(二)---客户端连接
    netty(一)---服务端源码阅读
    java NIO
    零拷贝
    计算机操作系统(复习)--- 虚拟内存
    疫情环境下的网络学习笔记 python 3.16
  • 原文地址:https://www.cnblogs.com/webmen/p/5739287.html
Copyright © 2011-2022 走看看