zoukankan      html  css  js  c++  java
  • HDOJ 1397 Goldbach's Conjecture(快速筛选素数法)

    Problem Description
    Goldbach’s Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.
    This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

    A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.

    Input
    An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.

    Output
    Each output line should contain an integer number. No other characters should appear in the output.

    Sample Input
    6
    10
    12
    0

    Sample Output
    1
    2
    1

    题意:
    哥德巴赫猜想:任何偶数n大于或等于4,至少存在一对素数P1和P2,n=p1+p2。p1+p2和p2+p1是一样的。
    本题是统计有多少对不同的素数和等于n.

    注意用到素数筛选,然后打表就可以得出答案了。

    import java.util.Scanner;
    
    public class Main{
        static int[] db = new int[65536];
        public static void main(String[] args) {
            dabiao();
            //System.out.println(Math.pow(2, 15));-32768
            Scanner sc = new Scanner(System.in);
            while(sc.hasNext()){
                int n = sc.nextInt();
                if(n==0){
                    return ;
                }
                int tp = 0;
                for(int i=1;i<=n/2;i++){
    
                    if(db[i]==1&&db[n-i]==1){
                        tp++;
                    }
                }
                System.out.println(tp);
    
            }
    
        }
    
        //快速筛选素数
        private static void dabiao() {
            for(int i=0;i<db.length;i++){
                db[i]=1;
            }
            db[0]=0;
            db[1]=0;
            for(int i=2;i<=Math.sqrt(db.length);i++){
                for(int j=i+i;j<db.length;j=j+i){
                    if(db[i]==1){
                        db[j]=0;
                    }
                }
            }
    
    //      for(int i=0;i<1000;i++){
    //          if(db[i]==1){
    //              System.out.println(i);
    //          }
    //      }
        }
    
    }
    
  • 相关阅读:
    KafkaOffsetMonitor
    锋利的KATANA
    用grunt搭建自动化的web前端开发环境
    网上书店订单功能的实现
    作用域和控制器
    使用CLK.AspNet.Identity提供以角色为基础的访问控制(RBAC)
    ABP日志管理
    .NET开源项目
    服务总线
    Message解析流程(转)
  • 原文地址:https://www.cnblogs.com/webmen/p/5739302.html
Copyright © 2011-2022 走看看