zoukankan      html  css  js  c++  java
  • 杭电1003-Max Sum

    Max Sum

    Problem Description
    Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
     
    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
     
    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
     
    Sample Input
    2
    5 6 -1 5 4 -7
    7 0 6 -1 1 -6 7 -5
     
    Sample Output
    Case 1:
    14 1 4
     
    Case 2:
    7 1 6
     

    #include <cstdlib>
    #include <iostream>

    using namespace std;

    int main(int argc, char *argv[])
    {
        int n,m,a,temp,start,end;
        long sum,max;
        cin>>n;
        for(int j=1;j<=n;j++)
        {
           cin>>m;
           sum=0;
           max=-1001;////由于存在全是负数,将最大值赋值为负数(更大也行)
           temp=1;
           for(int i=1;i<=m;i++)
           {
                   cin>>a;
                   sum+=a;
                   if(sum>max)
                   {
                      max=sum;
                      start=temp;//更新起始点
                      end=i;  //更新末点
                   }
                   if(sum<0)
                   {
                      sum=0;
                      temp=i+1;//执行下一个i(也就是读取下一个数字)
                   }
           }
           cout<<"Case "<<j<<":"<<endl;
           cout<<max<<" "<<start<<" "<<end<<endl;
           if(j<n)
           cout<<endl;
        }
        system("PAUSE");
        return EXIT_SUCCESS;
    }

  • 相关阅读:
    Vue学习(十七)修饰符
    组件学习(一)开发组件前必读
    vue学习(十六)“就地更新”策略
    nrm学习(一)
    帧动画的多种实现方式与性能对比
    JavaScript中的二进制对象
    生成式模型与判别式模型
    堡垒机
    vue生产环境nginx配置代理转发跨域
    Ceph nautilus 集群部署
  • 原文地址:https://www.cnblogs.com/wft1990/p/4316333.html
Copyright © 2011-2022 走看看