zoukankan      html  css  js  c++  java
  • Digital Roots 1013

    Digital Roots

    时间限制(普通/Java):1000MS/3000MS          运行内存限制:65536KByte
    总提交:456            测试通过:162

    描述

    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

    输入

    The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

    输出

    For each integer in the input, output its digital root on a separate line of the output.

    样例输入

    24
    39
    0

    样例输出

    6
    3

    当时数组开辟空间1000  死活通不过,稍大一点就可以

    #include <iostream>
    #include <cstring>
    using namespace std;
    
    int main()
    {
        char num[1005]; 
        int len; 
        while(cin.getline(num,1005)&& num[0]!='0')
        {
            len=strlen(num);
            int sum=0;
            for(int i=0;i<len;i++)
            {
                    sum+=num[i]-'0';//一般程序不用 48  而是0’ 
                    if(sum>=10)
                      sum=sum/10+sum%10;  //这个我开学讲过 如何求解一个数的每一位 
            }                     
            cout<<sum<<endl;
        }
              return 0;  
    }
    View Code
  • 相关阅读:
    tfs中如何创建团队项目及如何操作团队项目
    Qt出现常量有换行符的错误的解决方法
    .net程序在无.net环境下运行
    无法定位程序输入点__gxx_personality_v0的一个解决方法
    SQL Server2012中的SequenceNumber
    GDB十分钟教程
    使用vscode对c进行调试
    sqlserver 操作xml
    使用HttpOnly提升Cookie安全性
    SQL localdb 连接字符串
  • 原文地址:https://www.cnblogs.com/wft1990/p/6063623.html
Copyright © 2011-2022 走看看