zoukankan      html  css  js  c++  java
  • poj3461Oulipo

    Description

    The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

    Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

    Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

    So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

    Input

    The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

    • One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
    • One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

    Output

    For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

    Sample Input

    3
    BAPC
    BAPC
    AZA
    AZAZAZA
    VERDI
    AVERDXIVYERDIAN

    Sample Output

    1
    3
    0

    Source

    #include<iostream>
    #include<cstring>
    #include<cstdio>
    #include<cmath>
    
    using namespace std;
    
    char s1[11000],s2[1100000];
    int next[11000];
    int match[1100000];
    int main()
    {
        int n,i,j,k;
        cin>>n;
        getchar();
        for(i = 0;i<n;i++)
        {
            int num = 0;
            scanf("%s",s1+1);
            scanf("%s",s2+1);
            next[1] = 0;
            int l1 = strlen(s1+1);
            for(j = 2;j<l1+1;j++)
            {
                int t = next[j-1];
                while(t&&s1[j]!=s1[t+1]) t = next[t];
                if(s1[j] == s1[t+1])t++;
                next[j] = t;
            }
            int l2 = strlen(s2+1);
            match[0] = 0;
            for(j = 1;j<l2+1;j++)
            {
                int t = match[j-1];
                while(t&&s2[j]!=s1[t+1]) t = next[t];
                if(s2[j] == s1[t+1]) t++;
                match[j] = t;
                if(match[j] == l1) num++;
            }
            cout<<num<<endl;
        }
    }
  • 相关阅读:
    apache+tomcat分布式搭建
    maven 加入本地jar包
    一步一步搭建Jenkins环境
    缓存详解
    nginx配置文件注释
    mybatis like的用法
    Golang聊天室
    windows 10安装gensim、nltk
    理解矩阵乘法
    超赞的 Go 语言 INI 文件操作
  • 原文地址:https://www.cnblogs.com/wos1239/p/4388923.html
Copyright © 2011-2022 走看看