zoukankan      html  css  js  c++  java
  • 01-复杂度2. Maximum Subsequence Sum (25)

    Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

    Input Specification:

    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

    Output Specification:

    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

    Sample Input:

    10
    -10 1 2 3 4 -5 -23 3 7 -21
    

    Sample Output:

    10 1 4
    //#include<cstdio>
    //using namespace std;
    //const int maxn=100000+10;
    //int a[maxn];
    //int main()
    //{
    //    int n;
    //    int maxsum;
    //    int thissum;
    //    int start;
    //    int last;
    //    scanf("%d",&n);
    //    for(int i=0;i<n;i++)
    //    {
    //        scanf("%d",&a[i]);
    //    }
    //    maxsum=0;
    //    for(int i=0;i<n;i++)
    //    {
    //        thissum=0;
    //        for(int j=i;j<n;j++)
    //        {
    //            thissum+=a[j];
    //            if(thissum>=maxsum)
    //                {
    //                    maxsum=thissum;
    //                    start=i;
    //                    last=j;
    //                }
    //        }
    //    }
    //    if(maxsum>=0)
    //    printf("%d %d %d",maxsum,a[start],a[last]);
    //    else
    //        printf("0 0 %d",n-1);
    //    return 0;
    //}
    #include<cstdio>
    using namespace std;
    const int maxn=100000+10;
    int a[maxn];
    int main()
    {
        int n;
        int flag=0;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            if(a[i]>=0)//最大值为0
                flag=1;
        }
        int maxsum,thissum;
        int start,last;
        start=last=0;
        maxsum=thissum=0;
        int s=0;
        for(int i=0;i<n;i++)
        {
            thissum+=a[i];
            if(thissum>maxsum||(thissum==maxsum&&maxsum==0))
                {
                    maxsum=thissum;
                    last=i;
                    start=s;
                }
            if(thissum<0)
                {
                    thissum=0;
                    s=i+1;
                }
        }
        if(flag==1)
        printf("%d %d %d",maxsum,a[start],a[last]);
        else
            printf("0 %d %d",a[0],a[n-1]);//样例全是负数
        return 0;
    }
    

      

  • 相关阅读:
    js中细小点
    被 idea 坑了的记录篇
    Spring 读写分离
    Java反射机制
    Spring AOP
    java Beanutils.copyProperties( )用法
    java List 数组删除元素
    java 中序列化(Serializable)
    webpack 入门
    使用zxing生成彩色或带图片的二维码
  • 原文地址:https://www.cnblogs.com/wpnan/p/4350662.html
Copyright © 2011-2022 走看看