zoukankan      html  css  js  c++  java
  • 【洛谷 2984】给巧克力

    题目描述

    Farmer John is distributing chocolates at the barn for Valentine's day, and B (1 <= B <= 25,000) of his bulls have a special cow in mind to receive a chocolate gift.

    Each of the bulls and cows is grazing alone in one of the farm's N (2*B <= N <= 50,000) pastures conveniently numbered 1..N and connected by M (N-1 <= M <= 100,000) bidirectional cowpaths of various lengths. Some pastures might be directly connected by more than one cowpath. Cowpath i connects pastures R_i and S_i (1 <= R_i <= N; 1 <= S_i <= N) and has length L_i (1 <= L_i <= 2,000).

    Bull i resides in pasture P_i (1 <= P_i <= N) and wishes to give a chocolate to the cow in pasture Q_i (1 <= Q_i <= N).

    Help the bulls find the shortest path from their current pasture to the barn (which is located at pasture 1) and then onward to the pasture where their special cow is grazing. The barn connects, one way or another (potentially via other cowpaths and pastures) to every pasture.

    As an example, consider a farm with 6 pastures, 6 paths, and 3 bulls (in pastures 2, 3, and 5) who wish to bestow chocolates on their love-objects:

    
                          *1  <-- Bull wants chocolates for pasture 1 cow
                 [4]--3--[5]  <-- [5] is the pasture ID
                /  |
               /   |
              4    2          <-- 2 is the cowpath length
             /     |               between [3] and [4]
          [1]--1--[3]*6
         /       /
        9     3  2
       /       /
     [6]      [2]*4

    * The Bull in pasture 2 can travel distance 3 (two different ways) to get to the barn then travel distance 2+1 to pastures [3] and [4] to gift his chocolate. That's 6 altogether.

    * The Bull in pasture 5 can travel to pasture 4 (distance 3), then pastures 3 and 1 (total: 3 + 2 + 1 = 6) to bestow his chocolate offer.

    * The Bull in pasture 3 can travel distance 1 to pasture 1 and then take his chocolate 9 more to pasture 6, a total distance of 10.

    Farmer John有B头奶牛(1<=B<=25000),有N(2*B<=N<=50000)个农场,编号1-N,有M(N-1<=M<=100000)条双向边,第i条边连接农场R_i和S_i(1<=R_i<=N;1<=S_i<=N),该边的长度是L_i(1<=L_i<=2000)。居住在农场P_i的奶牛A(1<=P_i<=N),它想送一份新年礼物给居住在农场Q_i(1<=Q_i<=N)的奶牛B,但是奶牛A必须先到FJ(居住在编号1的农场)那里取礼物,然后再送给奶牛B。你的任务是:奶牛A至少需要走多远的路程?

    输入输出格式

    输入格式:

    * Line 1: Three space separated integers: N, M, and B

    * Lines 2..M+1: Line i+1 describes cowpath i with three

    space-separated integers: R_i, S_i, and L_i

    * Lines M+2..M+B+1: Line M+i+1 contains two space separated integers: P_i and Q_i

    输出格式:

    * Lines 1..B: Line i should contain a single integer, the smallest distance that the bull in pasture P_i must travel to get chocolates from the barn and then award them to the cow of his dreams in pasture Q_i

    输入输出样例

    输入样例#1: 复制
    6 7 3 
    1 2 3 
    5 4 3 
    3 1 1 
    6 1 9 
    3 4 2 
    1 4 4 
    3 2 2 
    2 4 
    5 1 
    3 6 
    
    输出样例#1: 复制
    6 
    6 
    10 
    

    说明

    输入格式:

    第一行:三个用空格隔开的整数N,M和B。

    第二到M+1行:第i+1行用R_i,S_i和L_i三个用空格隔开的整数描述双向边i。

    第M+2到M+B+1行:第M+i+1行包含两个用空格隔开的整数P_i和Q_i。

    输出格式:

    第一到B行:第i行包括一个整数,居住在农场P_i的公牛从FJ那里取得情人节巧克力后送给他居住在农场Q_i的梦中情牛至少需要走的距离。

    题解;原来想跑两遍最短路,后来发现,a-pj,pj-b这两次可以看作pj-a,pj-b,所以

    只要跑一次spfa即可(注意无向边,边数*2,忘记了,RE了1个点,哭了我)

    #include<cstdio>
    #include<iostream>
    #include<cmath>
    #include<cstdlib>
    #include<cstring>
    #include<algorithm>
    #include<queue>
    typedef long long ll;
    using namespace std;
    const int N=200005;
    struct node{
        int to;
        int next;
        int val;
    }e[N];
    int head[N],dis[N],cnt,vis[N];
    void add(int a,int b,int c){
        cnt++;
        e[cnt].to=b;
        e[cnt].val=c;
        e[cnt].next=head[a];
        head[a]=cnt;
    } 
    queue<int>q;
    int u,v;
    void spfa(){
        memset(dis,0x3f,sizeof(dis));
        q.push(1); dis[1]=0; vis[1]=1;
        while(!q.empty()){
            u=q.front();
            q.pop();
            vis[u]=0;
            for(int i=head[u];i;i=e[i].next){
                v=e[i].to;
                if(dis[v]>dis[u]+e[i].val){
                    dis[v]=dis[u]+e[i].val;
                    if(vis[v]==0){
                        vis[v]=1;
                        q.push(v);
                    }
                }
            }
        }
    }
    int n,m,b,x,y,z;
    int main(){
        freopen("2984.in","r",stdin);
        freopen("2984.out","w",stdout);
        scanf("%d %d %d",&n,&m,&b);
        for(int i=1;i<=m;i++){
            scanf("%d %d %d",&x,&y,&z);
            add(x,y,z); add(y,x,z);
        }
        spfa();
        //int ans=0x3f3f3f3f;
        while(b--){
            scanf("%d %d",&x,&y);
            //ans=min(ans,dis[x]+dis[y]);
            cout<<dis[x]+dis[y]<<endl;
        }
        //cout<<ans;
        return 0;
    }
  • 相关阅读:
    linuxshell中"2>&1"含义
    Java中正数与负数操作>>、>>>的区别
    jsp el表达式
    struct2常用标签
    shell正则表达式
    IPV6学起来很费力?你看看,也就这样简单吧!
    STP、RSTP、MSTP合集思维导图
    HCIE之路--ISIS思维导图
    佛祖保佑,永不宕机! 永无BUG!
    震惊!ARP安全竟然还可以这样配置?
  • 原文地址:https://www.cnblogs.com/wuhu-JJJ/p/11182176.html
Copyright © 2011-2022 走看看