zoukankan      html  css  js  c++  java
  • PAT 1016. Phone Bills

    A long-distance telephone company charges its customers by the following rules:

    Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made.  When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone.  Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day).  Your job is to prepare the bills for each month, given a set of phone call records.

    Input Specification:

    Each input file contains one test case.  Each case has two parts:  the rate structure, and the phone call records.

    The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

    The next line contains a positive number N (<= 1000), followed by N lines of records.  Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word "on-line" or "off-line".

    For each test case, all dates will be within a single month.  Each "on-line" record is paired with the chronologically next record for the same customer provided it is an "off-line" record.  Any "on-line" records that are not paired with an "off-line" record are ignored, as are "off-line" records not paired with an "on-line" record.  It is guaranteed that at least one call is well paired in the input.  You may assume that no two records for the same customer have the same time.  Times are recorded using a 24-hour clock.

    Output Specification:

    For each test case, you must print a phone bill for each customer.

    Bills must be printed in alphabetical order of customers' names.  For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample.  Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call.  The calls must be listed in chronological order.  Finally, print the total charge for the month in the format shown by the sample.

    Sample Input:

    10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
    10
    CYLL 01:01:06:01 on-line
    CYLL 01:28:16:05 off-line
    CYJJ 01:01:07:00 off-line
    CYLL 01:01:08:03 off-line
    CYJJ 01:01:05:59 on-line
    aaa 01:01:01:03 on-line
    aaa 01:02:00:01 on-line
    CYLL 01:28:15:41 on-line
    aaa 01:05:02:24 on-line
    aaa 01:04:23:59 off-line
    

    Sample Output:

    CYJJ 01
    01:05:59 01:07:00 61 $12.10
    Total amount: $12.10
    CYLL 01
    01:06:01 01:08:03 122 $24.40
    28:15:41 28:16:05 24 $3.85
    Total amount: $28.25
    aaa 01
    02:00:01 04:23:59 4318 $638.80
    Total amount: $638.80

    // 1016pat.cpp : 定义控制台应用程序的入口点。
    //
    
    #include <iostream>
    #include <vector>
    #include <map>
    #include <algorithm>
    #include <string>
    #include <iomanip>
    using namespace std;
    
    struct Call
    {
        string name;
        int month;
        int day;
        int hour;
        int minute;
        int total;
        string status;
        bool operator<(const Call& rhs) const
        {
            if(name==rhs.name)
                return total<rhs.total;
            else
                return name<rhs.name;
        }
    };
    
    map<int,int> toll;
    
    int calByTime(int time)
    {
        int hours=time/60;
        int minute=time%60;
        int money=0;
        int i;
        for(i=0;i<hours;++i)
            money+=toll[i%24]*60;
        money+=minute*toll[i%24];
        return money;
    }
    
    double calCost(const Call& s,const Call& t)
    {
        return (double)(calByTime(t.total)-calByTime(s.total))/100.0;
    }
    
    int calLast(const Call& s,const Call& t)
    {
        return (t.day-s.day)*24*60+(t.hour-s.hour)*60+(t.minute-s.minute);
    }
    
    int main()
    {
        int tmp;
        for(int i=0;i<24;++i)
        {
            cin>>tmp;
            toll[i]=tmp;
        }
        int n;
        cin>>n;
        Call call;
        vector<Call> all_calls;
        vector<Call> format_calls;
        char c;
        while(n--)
        {
            cin>>call.name;
            cin>>call.month;
            cin>>c;
            cin>>call.day;
            cin>>c;
            cin>>call.hour;
            cin>>c;
            cin>>call.minute;
            call.total=24*60*call.day+60*call.hour+call.minute;
            cin>>call.status;
            all_calls.push_back(call);
        }
        sort(all_calls.begin(),all_calls.end());
    
        //delete the dirty data;
        bool hasonline=false;
        string curname=" ";
        for(vector<Call>::iterator iter=all_calls.begin();iter!=all_calls.end();++iter)
        {
            if(hasonline==false&&iter->status=="on-line")
            {
                hasonline=true;
                curname=iter->name;
                format_calls.push_back(*iter);
            }
            else if(hasonline==true&&iter->status=="on-line")
            {
                format_calls.pop_back();
                format_calls.push_back(*iter);
                curname=iter->name;
            }
            else if(hasonline==true&&iter->status=="off-line"&&curname==iter->name)
            {
                format_calls.push_back(*iter);
                hasonline=false;
            }
        }
        if((format_calls.end()-1)->status=="on-line")
            format_calls.pop_back();
    
        //output the result;
        curname=" ";
        double total=0.0;
        double fee;
        for(vector<Call>::iterator iter=format_calls.begin();iter!=format_calls.end();++iter,++iter)
        {
            if(iter->name!=curname)
            {
                if(curname!=" ")
                {
                    cout<<"Total amount: $"<<fixed<<setprecision(2)<<total<<endl;
                    total=0.0;
                    cout<<iter->name<<" "<<setfill('0')<<setw(2)<<iter->month<<endl;
                }
                else
                {
                    cout<<iter->name<<" "<<setfill('0')<<setw(2)<<iter->month<<endl;
                }
                curname=iter->name;
            }
            cout<<setfill('0')<<setw(2)<<iter->day<<":"<<setfill('0')<<setw(2)<<iter->hour<<":"<<setfill('0')<<setw(2)<<iter->minute<<" ";
            cout<<setfill('0')<<setw(2)<<(iter+1)->day<<":"<<setfill('0')<<setw(2)<<(iter+1)->hour<<":"<<setfill('0')<<setw(2)<<(iter+1)->minute<<" ";
            cout<<calLast(*iter,*(iter+1))<<" ";
            fee=calCost(*iter,*(iter+1));
            cout<<"$"<<fixed<<setprecision(2)<<fee<<endl;;
            total+=fee;
        }
        cout<<"Total amount: $"<<fixed<<setprecision(2)<<total<<endl;
        return 0;
    }
    View Code
  • 相关阅读:
    python抢票开发——设备预约助手实现
    树莓派的基本网络配置
    python 端口扫描程序
    数据通讯与网络 第五版第24章 传输层协议-TCP协议部分要点
    数据通讯与网络 第五版第24章 传输层协议-UDP协议部分要点
    利用python开发的flappy bird 游戏
    EMACS 快捷键笔记
    python程序中用类变量代替global 定义全局变量
    在树莓派下对多个串口转USB设备进行设备名称绑定操作
    python 编写的经纬度坐标转换类
  • 原文地址:https://www.cnblogs.com/wwblog/p/3656571.html
Copyright © 2011-2022 走看看