zoukankan      html  css  js  c++  java
  • hdu 1213 (How Many Tables)(简单的并查集,纯模板)

    How Many Tables

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 14081    Accepted Submission(s): 6912


    Problem Description
    Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

    One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

    For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
     

    Input
    The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
     

    Output
    For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
     

    Sample Input
    2 5 3 1 2 2 3 4 5 5 1 2 5
     

    Sample Output
    2 4
     

    Author
    Ignatius.L
     

    Source

    考察知识点:
    并查集。
    代码例如以下:
    #include<stdio.h>
    int a[10010];
    int f(int x)
    {
    	int r=x;
    	while(r!=a[r])
    	r=a[r];
    	return r;
    }
    void merge(int x,int y)//此处是int语句的最后加上一个return 0;也是能够的 
    {
    	int fx=f(x);
    	int fy=f(y);
    	if(fx!=fy)
    	{
    		a[fx]=fy;
    	}
    }
    int main()
    {
    	int t;
    	scanf("%d",&t);
    	while(t--)
    	{
    		int i,n,m,x,y;
    		scanf("%d%d",&n,&m);
    		for(i=1;i<=n;i++)//必须从一開始 ,从零開始就WA 
    		{
    			a[i]=i;//初始化,并作为最后判定的条件。

    //将每一个人的根节点初始化自身。最后统计总的根节点的个数 } for(i=0;i<m;i++) { scanf("%d%d",&x,&y); merge(x,y);//压缩路径函数,降低跟点数量,也就是将认识的人合并 } int count=0; for(i=1;i<=n;i++) { if(a[i]==i) count++; } printf("%d ",count); } return 0; }



  • 相关阅读:
    Android开发之下载服务器上的一张图片到本地java代码实现HttpURLConnection
    控制台——屏蔽Ctrl+C快捷键对窗体的关闭功能
    控制台——禁用关闭按钮
    控制台——对WIN32 API的使用(user32.dll)
    控制台——对窗口句柄的操作
    控制台——防止程序重复启动
    Json——一般应用
    SQL——将两列合并成一列
    Xamarin在VS2012没有智能提示的解决办法
    C#的Xamarin开发小米盒子应用并以WCF实现微信通知
  • 原文地址:https://www.cnblogs.com/wzjhoutai/p/6745442.html
Copyright © 2011-2022 走看看