zoukankan      html  css  js  c++  java
  • HDU 1075 What Are You Talking About (Trie)

    What Are You Talking About

    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
    Total Submission(s): 16042    Accepted Submission(s): 5198


    Problem Description
    Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
     

    Input
    The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab(' '), enter(' ') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
     

    Output
    In this problem, you have to output the translation of the history book.
     

    Sample Input
    START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
     

    Sample Output
    hello, i'm from mars. i like earth!




    解析:将词典中的原始单词组织成Trie,相应的相应单词作为原始单词的附加信息放到Trie树中原始单词的最后一个字符结点中。




    AC代码:

    //#include <bits/stdc++.h>       //hdu的C++,不支持此头文件。G++支持
    #include <cstdio>
    #include <cstring>
    #include <cctype>
    
    using namespace std;
    
    const int maxw = 12;
    const int maxnode = 100000 * maxw + 10;
    const int sigma_size = 26;
    
    struct Trie{
        int ch[maxnode][sigma_size];
        char val[maxnode][maxw];
        int sz;
    
        void clear(){ sz = 1; memset(ch[0], 0, sizeof(ch[0])); }
        int idx(char c){ return c - 'a'; }
    
        void insert(const char *s, const char *v){
            int u = 0, n = strlen(s);
            for(int i=0; i<n; i++){
                int c = idx(s[i]);
                if(!ch[u][c]){
                    memset(ch[sz], 0, sizeof(ch[sz]));
                    ch[u][c] = sz++;
                }
                u = ch[u][c];
            }
            strcpy(val[u], v);
        }
    
        char* find(const char *s){
            int u = 0, n = strlen(s);
            int i;
            char ans[maxw];
            for(i=0; i<n; i++){
                int c = idx(s[i]);
                if(!ch[u][c]) return "";
                u = ch[u][c];
            }
            return val[u];
        }
    };
    
    Trie trie;
    
    int main(){
        #ifdef sxk
            freopen("in.txt", "r", stdin);
        #endif // sxk
    
        trie.clear();
        char s[maxw], ss[maxw], text[3002];
        scanf("%s", s);
        while(scanf("%s", s)){
            if(s[0] == 'E' && s[1] == 'N' && s[2] == 'D') break;
            scanf("%s", ss);
            trie.insert(ss, s);
        }
        scanf("%s", s);
        getchar();
        while(gets(text)){
            if(text[0] == 'E' && text[1] == 'N' && text[2] == 'D') break;
            int n = strlen(text);
            for(int i=0; i<n; ){
                char foo[maxw];
                int cnt = 0;
                while(i < n && isalpha(text[i])){ foo[cnt ++] = text[i ++]; }
                foo[cnt] = '';
                if(!cnt){ putchar(text[i ++]); continue; }
                if(strcmp(trie.find(foo), "")) printf("%s", trie.find(foo));
                else printf("%s", foo);
            }
            puts("");
        }
        return 0;
    }
    



  • 相关阅读:
    微信小程序 开发 微信开发者工具 快捷键
    .NET 4.0 任务(Task)
    MVC UpdateModel的未能更新XXXXX的类型模型
    ORACLE 定时执行存储过程
    DotNet 资源大全中文版(Awesome最新版)
    基于SignalR实现B/S系统对windows服务运行状态的监测
    Method not found: '!!0[] System.Array.Empty()'.
    MVC-RedirectToAction跳转到其他Area
    C# where用法
    C#委托的介绍(delegate、Action、Func、predicate)
  • 原文地址:https://www.cnblogs.com/wzjhoutai/p/6746877.html
Copyright © 2011-2022 走看看