zoukankan      html  css  js  c++  java
  • J

    The Sky is Sprite.
    The Birds is Fly in the Sky.
    The Wind is Wonderful.
    Blew Throw the Trees
    Trees are Shaking, Leaves are Falling.
    Lovers Walk passing, and so are You.
    ................................Write in English class by yifenfei

    Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
    Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy Xa + Yb = 1. If no such answer print "sorry" instead.

    Input

    The input contains multiple test cases.
    Each case two nonnegative integer a,b (0<a, b<=2^31)

    Output

    output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.

    Sample Input

    77 51
    10 44
    34 79

    Sample Output

    2 -3
    sorry
    7 -3

    直接用拓展欧几里得,但是注意Find the nonnegative integer X and integer Y,f there are more answers than the X smaller one will be choosed.

    #include<iostream>
    #include<stdio.h>
    #include<stdlib.h>
    #include<cmath>
    #include<string.h>
    #include<algorithm>
    #define sf scanf
    #define pf printf
    #define pb push_back
    #define mm(a,b) memset((a),(b),sizeof(a))
    #include<vector>
    typedef __int64 ll;
    typedef long double ld;
    const ll mod=1e9+7;
    using namespace std;
    const double pi=acos(-1.0);
    ll exgcd(ll a,ll b,ll &x,ll &y)//x,y在输入的时候不用定义
    {
        int d, t;
        if(b==0)
        {
            x=1;
            y=0;
            return a;
        }else
        {
            d = exgcd(b, a % b,x,y);
            t = x - a / b * y;
       		x = y;
            y = t;
            return d;    
        }
    }
    int main()
    {
    	ll a,b,r,x,y;
    	while(~scanf("%I64d%I64d",&a,&b))
    	{
    		r=exgcd(a,b,x,y);
    		if(r!=1)
    		pf("sorry
    ");
    		else
    		{
    			while(x<0)
    			{
    				x+=b;
    				y-=a;
    			}
    			pf("%I64d %I64d
    ",x,y);
    		}
    		
    	}
    	return 0;
    }
    
  • 相关阅读:
    POJ
    POJ
    操作系统
    POJ
    POJ
    codeforces Educational Round 89
    codeforces Round 647(div. 2)
    codeforces Educational Round 88
    后缀自动机简单总结
    dsu on tree 简单总结
  • 原文地址:https://www.cnblogs.com/wzl19981116/p/9361773.html
Copyright © 2011-2022 走看看