zoukankan      html  css  js  c++  java
  • Jessica's Reading Problem

    第一部分:题目

    Description

    Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

    A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

    Input

    The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

    Output

    Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

    Sample Input

    5
    1 8 8 8 1
    

    Sample Output

    2

    第二部分:代码

    /*
    学会使用set、map来简化操作。 
    */
    #include<iostream>
    #include<stdio.h>
    #include<set>
    #include<map>
    using namespace std;
    int main()
    {
        int page[1000010],n;
        cin>>n;
        //利用set中不存在相同元素的特点计算有多少个不同的知识点 
        set<int> all;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&page[i]); 
            //cin>>page[i];//这里使用cin真的慢,贼慢 
            all.insert(page[i]);
        }
        int point=all.size();//有多少个不同的知识点 
        //尺取法:通俗点,就是一段一段看 
        int s=0,t=0,num=0;
        int min=n;
        map<int,int> fuck;//知识点->出现次数 
        while(1)
        {
            while(t<n&&num<point)
            {
                //出现新的知识点 
                if(fuck[page[t++]]++==0)
                {
                    num++;
                }
            }
            if(num<point)
            {
                break;
            }
            if(min>t-s)
            {
                min=t-s;
            }
            //去除了一个知识点 
            if(--fuck[page[s++]]==0)
            {
                num--;
            }
        }
        cout<<min<<endl;
        return 0;
    }
    View Code
  • 相关阅读:
    APNS 证书生成注意事项
    Remove a Submodule within git
    Quartz.NET
    Linux.net && mono
    系统整理qt笔记1
    串口通讯之rs232 c++版本
    串口通信 之 linux固定串口别名的两种方法
    系统整理qt笔记3
    串口通信+进制基础+位运算
    qt(二)
  • 原文地址:https://www.cnblogs.com/xiangguoguo/p/5528496.html
Copyright © 2011-2022 走看看