zoukankan      html  css  js  c++  java
  • 广度优先搜素和深度优先搜素

    以北大的1979为例:

    Red and Black
    Time Limit: 1000MS   Memory Limit: 30000K
    Total Submissions: 17144   Accepted: 9025

    Description

    There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

    Write a program to count the number of black tiles which he can reach by repeating the moves described above.

    Input

    The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

    There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

    '.' - a black tile
    '#' - a red tile
    '@' - a man on a black tile(appears exactly once in a data set)
    The end of the input is indicated by a line consisting of two zeros.

    Output

    For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

    Sample Input

    6 9
    ....#.
    .....#
    ......
    ......
    ......
    ......
    ......
    #@...#
    .#..#.
    11 9
    .#.........
    .#.#######.
    .#.#.....#.
    .#.#.###.#.
    .#.#..@#.#.
    .#.#####.#.
    .#.......#.
    .#########.
    ...........
    11 6
    ..#..#..#..
    ..#..#..#..
    ..#..#..###
    ..#..#..#@.
    ..#..#..#..
    ..#..#..#..
    7 7
    ..#.#..
    ..#.#..
    ###.###
    ...@...
    ###.###
    ..#.#..
    ..#.#..
    0 0

    Sample Output

    45
    59
    6
    13

    具体要求:

    输入相应的格子的数目,并且标记每个格子的颜色,当遇到黑色的格子时可以踩上,当遇到红色的格子时不能踩上,要求输出从一个起始点出发能够踩到的黑色格子数。

     

    算法思想:

    1,  可以根据图的深度优先搜索,计算并输出通过深度搜索所通过的节点数,即相应的格子数目。

    2,  可以根据图的广度优先搜索,计算并输出通过广度搜索所通过的节点数,即相应的格子数目。

     

    算法实现:

    1,  深度优先搜索:通过递归方法,从图结构的一个结点开始深度搜索。相应的代码如下

    #include<stdio.h>
    #include<string.h>
    int a,b,n,m;
    char c[22][22];
    int sert(int a,int b)
    {
        if(c[a][b]=='#'||a>=m||b>=n||a<0||b<0)
            return 0;
        else
        {
            c[a][b]='#';
            return 1+sert(a,b+1)+sert(a,b-1)+sert(a-1,b)+sert(a+1,b);
        }
    }
    int main()
    {
        int i,j;
        while(scanf("%d%d",&n,&m),n||m)
        {
            for(i=0;i<m;i++)
            {
                getchar();
                for(j=0;j<n;j++)
                {
                    scanf("%c",&c[i][j]);
                    if(c[i][j]=='@')
                    {
                        a=i;b=j;
                    }
                }
            }
                n=sert(a,b);
                printf("%d\n",n);
        }
        return 0;
    }

    广度优先搜索:通过建立队列实现广度搜索,每走到符合要求的格子时,当前格子进队列。相应的代码如下:

    #include<stdio.h>
    #include<iostream>
    #include<queue>
    using namespace std;
    typedef struct
    {
        int x,y;
    }node;
    int n,m,a,b;
    char c[25][25];
    void sert()
    {
        int i,f[4][2]={0,1,0,-1,1,0,-1,0},p=0;;
        queue<node> q;  
        node t,temp;
        t.x=a;
        t.y=b;
        q.push(t);
        while(!q.empty())
        {
           t=q.front();
           q.pop();
           for(i=0;i<4;i++)
           {
               temp.x=t.x+f[i][0];
               temp.y=t.y+f[i][1];
               if(temp.x>=0&&temp.x<m&&temp.y<n&&temp.y>=0&&c[temp.x][temp.y]!='#')
               {
                   p++;
                   q.push(temp);
                   c[temp.x][temp.y]='#';
               }
           }
        }
        printf("%d\n",p);
    }
    int main()
    {
        int i,j;
        while(scanf("%d%d",&n,&m),n||m)
        {
            for(i=0;i<m;i++)
            {
                getchar();
                for(j=0;j<n;j++)
                {
                    scanf("%c",&c[i][j]);
                    if(c[i][j]=='@')
                    {
                        a=i;
                        b=j;
                    }
                }
            }
                sert();
        }
        return 0;
    }

     

     

  • 相关阅读:
    Documents
    gitlab 安装和配置
    git相关知识
    马俊龙ansible教程分享
    源码安装python 报错,openssl: error while loading shared libraries: libssl.so.1.1
    jumpserver 常见错误解决
    nginx 定义:响应头和请求头
    gcc入门(下)
    gcc入门(上)
    awk命令
  • 原文地址:https://www.cnblogs.com/xiaofanke/p/2651350.html
Copyright © 2011-2022 走看看