zoukankan      html  css  js  c++  java
  • poj 1887 导弹拦截

    A military contractor for the Department of Defense has just completed a series of preliminary tests for a new defensive missile called the CATCHER which is capable of intercepting multiple incoming offensive missiles. The CATCHER is supposed to be a remarkable defensive missile. It can move forward, laterally, and downward at very fast speeds, and it can intercept an offensive missile without being damaged. But it does have one major flaw. Although it can be fired to reach any initial elevation, it has no power to move higher than the last missile that it has intercepted.

    The tests which the contractor completed were computer simulations of battlefield and hostile attack conditions. Since they were only preliminary, the simulations tested only the CATCHER's vertical movement capability. In each simulation, the CATCHER was fired at a sequence of offensive missiles which were incoming at fixed time intervals. The only information available to the CATCHER for each incoming missile was its height at the point it could be intercepted and where it appeared in the sequence of missiles. Each incoming missile for a test run is represented in the sequence only once.

    The result of each test is reported as the sequence of incoming missiles and the total number of those missiles that are intercepted by the CATCHER in that test.

    The General Accounting Office wants to be sure that the simulation test results submitted by the military contractor are attainable, given the constraints of the CATCHER. You must write a program that takes input data representing the pattern of incoming missiles for several different tests and outputs the maximum numbers of missiles that the CATCHER can intercept for those tests. For any incoming missile in a test, the CATCHER is able to intercept it if and only if it satisfies one of these two conditions:

    The incoming missile is the first missile to be intercepted in this test.
    -or-
    The missile was fired after the last missile that was intercepted and it is not higher than the last missile which was intercepted.

    Input

    The input data for any test consists of a sequence of one or more non-negative integers, all of which are less than or equal to 32,767, representing the heights of the incoming missiles (the test pattern). The last number in each sequence is -1, which signifies the end of data for that particular test and is not considered to represent a missile height. The end of data for the entire input is the number -1 as the first value in a test; it is not considered to be a separate test.

    Output

    Output for each test consists of a test number (Test #1, Test #2, etc.) and the maximum number of incoming missiles that the CATCHER could possibly intercept for the test. That maximum number appears after an identifying message. There must be at least one blank line between output for successive data sets.

    Note: The number of missiles for any given test is not limited. If your solution is based on an inefficient algorithm, it may not execute in the allotted time.

    Sample Input

    389 207 155 300 299 170 158 65 -1 23 34 21 -1 -1

    Sample Output

    Test #1:   maximum possible interceptions: 6  Test #2:   maximum possible interceptions: 2 
     
    题意: 
        输入一组数据,求最大不连续降序数值个数。
     
    输入:
        每组数据以-1结束,连续两个-1则程序结束。
     
    输出:
        输出测试数据组数及求出的最大值。
     
        本题是经典的DP入门题目。用b[i]代表第i个数前的最大降序个数,这里i及为状态。遍历i以前的数值,若a[i]<a[j]则可形成新的降序数列,再判断b[i]<b[j]+1,若成立,则表示当前遍历到的a[j]可与a[i]形成新的最大降序数列,令b[i]=b[j]+1,记录最大降序数列长度。
    代码:
    #include<iostream>
    using namespace std ;
    int main(){
        int a[10000] ;
        int b[10000] ;
        int t, max, m = 0 ;
        while(true){
            cin >> t ;
            if(t==-1)   break ;
            int n = 1 ;
            a[n] = t ;
            while(true){
                cin >> t ;
                if(t==-1)   break ;
                n ++ ;
                a[n] = t ;
            }
            max = 0 ;
            for(int i=1; i<=n; i++){        //以i结束的数值倒序判断
                b[i] = 1 ;
                for(int j=1; j<=i-1; j++)
                    if(a[i]<a[j]&&b[i]<b[j]+1)  b[i] = b[j] + 1 ;   //遍历i之前的数值,若数值小于某一值,且当前最大降序值小于某值++,则更改b[i]
                if(max < b[i])  max = b[i] ;            //记录过程中的最大降序数列长度
            }
            m ++ ;
            cout << "Test #" << m << ":" << endl ;
            cout << "  maximum possible interceptions: " << max << endl << endl ;
        }
        return 0 ;
    }
  • 相关阅读:
    linux驱动开发学习一:创建一个字符设备
    如何高效的对有序数组去重
    找到缺失的第一个正整数
    .NET不可变集合已经正式发布
    中国人唯一不认可的成功——就是家庭的和睦,人生的平淡【转】
    自己动手搭建 MongoDB 环境,并建立一个 .NET HelloWorld 程序测试
    ASP.NET MVC 中如何用自定义 Handler 来处理来自 AJAX 请求的 HttpRequestValidationException 错误
    自己动手搭建 Redis 环境,并建立一个 .NET HelloWorld 程序测试
    ServiceStack 介绍
    一步一步实战扩展 ASP.NET Route,实现小写 URL、个性化 URL
  • 原文地址:https://www.cnblogs.com/xiaolongchase/p/2137827.html
Copyright © 2011-2022 走看看