zoukankan      html  css  js  c++  java
  • poj 1953 Workd Cup Noise

    Description

    Background
    "KO-RE-A, KO-RE-A" shout 54.000 happy football fans after their team has reached the semifinals of the FIFA World Cup in their home country. But although their excitement is real, the Korean people are still very organized by nature. For example, they have organized huge trumpets (that sound like blowing a ship's horn) to support their team playing on the field. The fans want to keep the level of noise constant throughout the match.
    The trumpets are operated by compressed gas. However, if you blow the trumpet for 2 seconds without stopping it will break. So when the trumpet makes noise, everything is okay, but in a pause of the trumpet,the fans must chant "KO-RE-A"!
    Before the match, a group of fans gathers and decides on a chanting pattern. The pattern is a sequence of 0's and 1's which is interpreted in the following way: If the pattern shows a 1, the trumpet is blown. If it shows a 0, the fans chant "KO-RE-A". To ensure that the trumpet will not break, the pattern is not allowed to have two consecutive 1's in it.
    Problem
    Given a positive integer n, determine the number of different chanting patterns of this length, i.e., determine the number of n-bit sequences that contain no adjacent 1's. For example, for n = 3 the answer is 5 (sequences 000, 001, 010, 100, 101 are acceptable while 011, 110, 111 are not).

    Input

    The first line contains the number of scenarios.
    For each scenario, you are given a single positive integer less than 45 on a line by itself.

    Output

    The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the number of n-bit sequences which have no adjacent 1's. Terminate the output for the scenario with a blank line.

    Sample Input

    2 3 1

    Sample Output

    Scenario #1: 5  Scenario #2: 2

    题意:
        给定0或1的个数,求出所有的不包括连续1的排列。

        数据量较小,直接算出所有答案即可。

    代码:
     
    #include<iostream>
    using namespace std ;
    int dp0[50] ;
    int dp1[50] ;
    int main(){
        dp0[1] = dp1[1] = 1 ;
        for(int i=2; i<=45; i++){
            dp0[i] = dp0[i-1] + dp1[i-1] ;      //若尾数为0,则前一位可以是0也可以是1,排列数为两者之和
            dp1[i] = dp0[i-1] ;                 //若尾数为1,则前一位只能是0,排列数为dp0[i-1]
        }
        int n, k ;
        cin >> n ;
        for(int i=1; i<=n; i++){
            cin >> k ;
            cout << "Scenario #" << i << ":" << endl << dp0[k]+dp1[k] << endl << endl ;
        }
        return 0 ;
    }
  • 相关阅读:
    Shiro 学习笔记(Realm)
    Shiro 学习笔记(Authentication)
    Shiro 学习笔记(基本结构)
    POI 示例(导入,导出)
    SpringBoot 整合POI
    解决使用drf-haystack报错ImportError: cannot import name get_count
    python实现冒泡排序和插入排序
    九大排序算法总结(转)
    Djaong 数据库查询
    django session 和cookie的设置,获取和删除
  • 原文地址:https://www.cnblogs.com/xiaolongchase/p/2137838.html
Copyright © 2011-2022 走看看