zoukankan      html  css  js  c++  java
  • sicily 1051 小数的有效数字

    1051. Biker's Trip Odomete

    Constraints

    Time Limit: 1 secs, Memory Limit: 32 MB

    Description

    Most bicycle speedometers work by using a Hall Effect sensor fastened to the front fork of the bicycle. A magnet is attached to one of the spokes on the front wheel so that it will line up with the Hall Effect switch once per revolution of the wheel. The speedometer monitors the sensor to count wheel revolutions. If the diameter of the wheel is known, the distance traveled can be easily be calculated if you know how many revolutions the wheel has made. In addition, if the time it takes to complete the revolutions is known, the average speed can also be calculated.

    For this problem, you will write a program to determine the total distance traveled (in miles) and the average speed (in Miles Per Hour) given the wheel diameter, the number of revolutions and the total time of the trip. You can assume that the front wheel never leaves the ground, and there is no slipping or skidding.

    Input

    Input consists of multiple datasets, one per line, of the form:

    diameter revolutions time

    The diameter is expressed in inches as a floating point value. The revolutions is an integer value. The time is expressed in seconds as a floating point value. Input ends when the value of revolutions is 0 (zero).

    Output

    For each data set, print:

    Trip #N: distance MPH

    Of course N should be replaced by the data set number, distance by the total distance in miles (accurate to 2 decimal places) and MPH by the speed in miles per hour (accurate to 2 decimal places). Your program should not generate any output for the ending case when revolutions is 0.

    Constants

    For p use the value: 3.1415927.
    There are 5280 feet in a mile.
    There are 12 inches in a foot.
    There are 60 minutes in an hour.
    There are 60 seconds in a minute.
    There are 201.168 meters in a furlong.

    Sample Input

    26 1000 5
    27.25 873234 3000
    26 0 1000

    Sample Output

    Trip #1: 1.29 928.20
    Trip #2: 1179.86 1415.84
    #include <iostream>
    #include <iomanip>
    using namespace std;
    int main () {
    	float diameter, revolution, time;
    	int number = 1;
    	while (cin >> diameter >> revolution >> time) {
    		if (revolution == 0) {
    			break;
    		}
    		float perimeter = 3.1415927 * ((diameter/12)/5280);
    		float distance = revolution * perimeter;
    		float mph = distance / (time/3600);
             //小数有效数字 cout << "Trip #" << number++ << ": "<< setprecision(2) << setiosflags(ios::fixed) << distance << " "<< mph << endl; } return 0; }

      

  • 相关阅读:
    很牛逼的android真机调试,手机、平板、电视都可
    设置TextView文字居中
    设置文本编辑器的按回车时触发的事件
    windows搭建virtualbox虚拟机安装的android环境
    Android EditText不弹出输入法焦点问题的总结
    MAVEN 的常用命令
    PuTTY_0.67.0.0工具链接linux
    CentOS6.8安装
    互亿无线短信验证码
    MYSQL: sql中某一个字段内容为用逗号分割的字符串转换成多条数据
  • 原文地址:https://www.cnblogs.com/xieyizun-sysu-programmer/p/decimal.html
Copyright © 2011-2022 走看看