zoukankan      html  css  js  c++  java
  • 1438. Shopaholic

    Constraints

    Time Limit: 1 secs, Memory Limit: 32 MB 

    Description

    Lindsay is a shopaholic. Whenever there is a discount of the kind where you can buy three items and only pay for two, she goes completely mad and feels a need to buy all items in the store. You have given up on curing her for this disease, but try to limit its effect on her wallet. You have realized that the stores coming with these offers are quite selective when it comes to which items you get for free; it is always the cheapest ones. As an example, when your friend comes to the counter with seven items, costing 400, 350, 300, 250, 200, 150, and 100 dollars, she will have to pay 1500 dollars. In this case she got a discount of 250 dollars. You realize that if she goes to the counter three times, she might get a bigger discount. E.g. if she goes with the items that costs 400, 300 and 250, she will get a discount of 250 the first round. The next round she brings the item that costs 150 giving no extra discount, but the third round she takes the last items that costs 350, 200 and 100 giving a discount of an additional 100 dollars, adding up to a total discount of 350. Your job is to find the maximum discount Lindsay can get.

    Input

    The first line of input gives the number of test scenarios, 1 ≤ t ≤ 20. Each scenario consists of two lines of input. The first gives the number of items Lindsay is buying, 1 ≤ n ≤ 20000. The next line gives the prices of these items, 1 ≤ pi ≤ 20000.

    Output

    For each scenario, output one line giving the maximum discount Lindsay can get by selectively choosing which items she brings to the counter at the same time.

    Sample Input

    1
    6
    400 100 200 350 300 250

    Sample Output

    400
    分析:
    排序,隔三求和,要注意的是从大到小而不是从小到大
    #include <iostream>
    #include <vector>
    #include <algorithm>
    
    using namespace std;
    
    bool cmp(int a, int b) {
        return a >= b;
    }
    
    int main(int argc, char const *argv[])
    {
        int testNum;
        int itemNum;
        int itemValue;
        vector<int> items;
        cin >> testNum;
        while (testNum--) {
            cin >> itemNum;
            items.resize(itemNum);
            for (int i = 0; i != itemNum; ++i) {
                cin >> itemValue;
                items[i] = itemValue;
            }
            sort(items.begin(), items.end(), cmp);
            int maxDiscount = 0;
            itemNum /= 3;
            for (int i = 0; i < itemNum; ++i) {
                maxDiscount += items[3 * i + 2];
            }
            cout << maxDiscount << endl;
        }
        return 0;
    }
  • 相关阅读:
    Scrapy学习-18-去重原理
    Scrapy学习-17-暂停和重启
    Scrapy学习-16-动态网页技术
    Scrapy学习-15-降低被识别为爬虫的方法
    Scrapy学习-14-验证码识别
    Scrapy学习-13-使用DownloaderMiddleware设置IP代理池及IP变换
    Scrapy学习-12-使用DownloaderMiddleware随机修改User-Agent
    Scrapy学习-11-Selector对象使用
    使用grunt完成requirejs的合并压缩和js文件的版本控制
    nodemailer中的几个坑
  • 原文地址:https://www.cnblogs.com/xiezhw3/p/4019712.html
Copyright © 2011-2022 走看看