zoukankan      html  css  js  c++  java
  • ACM寻找连续的数的乘积最大值

    Given a sequence of integers S = {S1, S2, . . . , Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.

    Input

    Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si is an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).

    Output

    For each test case you must print the message: ‘Case #M: The maximum product is P.’, where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.

    Sample Input 3 2 4 -3 5 2 5 -1 2 -1

    Sample Output

    Case #1:The maximum product is 8.

    Case #2: The maximum product is 20.

    解题思路:这个题目的大意是让我们寻找连续的数的乘积的最大值。我们用两个for循环就解决掉了这两个问题,然后比较得出最大的乘积数。

    程序代码:

    #include <iostream>
    using namespace std;
    int a[22];
    int main()
    {
        int n,v=0;
        long t;
        while(cin>>n&&n)
        {
            v++;
            long min=0;
            for(int i=0;i<n;i++)
                cin>>a[i];
            for(int k=0;k<n;k++)
            {
                t=1;
                for(int j=k;j<n;j++)
                {
                    t=t*a[j];
                    if(t>min)
                        min=t;
                }
            }
            cout<<"Case #"<<v<<": The maximum product is "<<min<<"."<<endl<<endl;
    
        }
        return 0;
    
    }
  • 相关阅读:
    SDUT 猴子分桃
    SDUT 母牛的故事
    SDUT 小鑫の日常系列故事(六)——奇遇记 递推算法
    SDUT 爬楼梯
    SDUT 王小二切饼
    linux 排序命令sort
    shell 判断语句
    shell统计指定范围内的所有质数以及它们的和
    shell 1到指定数累加
    shell九九乘法表
  • 原文地址:https://www.cnblogs.com/xinxiangqing/p/4688350.html
Copyright © 2011-2022 走看看