zoukankan      html  css  js  c++  java
  • hdu1002——A + B Problem II

    原题:

    Problem Description
    I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
     


     

    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
     


     

    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
     


     

    Sample Input
    2 1 2 112233445566778899 998877665544332211
     


     

    Sample Output
    Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

    分析:

    模拟进制,字符串处理;

    原码:

    #include<stdio.h>
    #include<string.h>
    int main()
    {
        char a1[1002],a2[1002];
        int c,i,j,n,m,s1[1002],s2[1002],l1,l2,count;
        count=1;
        scanf("%d",&n);
        m=n;
        while(m--)
        {
            memset(s1,0,sizeof(s1));
            memset(s2,0,sizeof(s2));//s1、s2全部赋值为0;
            scanf("%s%s",a1,a2);
            l1=strlen(a1);
            l2=strlen(a2);
            c=0;
            for(i=l1-1; i>=0; i--)
            {
                s1[c++]=a1[i]-'0';
            }
            c=0;//将字符串转换成数字
            for(i=l2-1; i>=0; i--)
            {
    
                s2[c++]=a2[i]-'0';
            }//将字符串转换成数字
            for(i=0; i<1002; i++)
            {
                s1[i]+=s2[i];//逐位相加
                if(s1[i]>=10)//判断是否进位
                {
                    s1[i]-=10;
                    s1[i+1]++;//进位
                }
            }
            printf("Case %d:\n",count++);
            printf("%s + %s = ",a1,a2);
            for(i=1001; i>=0; i--)
            {
                if(s1[i])
                    break;
            }   //跳出多余的0;
            for(j=i; j>=0; j--)
            {
    
                printf("%d",s1[j]);//已经跳出多余的0,依次输出。
            }
            printf("\n");
            if(count!=n+1)
                printf("\n");
        }
        return 0;
    }
    


     

  • 相关阅读:
    js:DOM及其操作2
    js:DOM及其操作
    闭包,作用域,作用域链
    面向对象
    关于typeof
    javascript正则表达式&关键词检索
    关于StringAPI
    mybatis Invalid bound statement (not found)
    全国区域数据
    redis 问题整理
  • 原文地址:https://www.cnblogs.com/xinyuyuanm/p/2998557.html
Copyright © 2011-2022 走看看