zoukankan      html  css  js  c++  java
  • 问题一百二十七:Keep on Truckin

    Description

    Boudreaux and Thibodeaux are on the road again . . .

    "Boudreaux, we have to get this shipment of mudbugs to Baton Rouge by tonight!"

    "Don't worry, Thibodeaux, I already checked ahead. There are three underpasses and our 18-wheeler will fit through all of them, so just keep that motor running!"

    "We're not going to make it, I say!"

    So, which is it: will there be a very messy accident on Interstate 10, or is Thibodeaux just letting the sound of his own wheels drive him crazy?

    Input

     

    Input to this problem will consist of multiple data sets. Each data set will be formatted according to the following description.

    The data set will consist of a single line containing 3 numbers, separated by single spaces. Each number represents the height of a single underpass in inches. Each number will be between 0 and 300 inclusive.

    The data sets end with a negetive integer.

    Output

    There will be exactly one line of output. This line will be:

       NO CRASH

    if the height of the 18-wheeler is less than the height of each of the underpasses, or:

       CRASH X

    otherwise, where X is the height of the smallest underpass in the data set that the 18-wheeler is unable to go under (which means its height is less than or equal to the height of the 18-wheeler).
    The height of the 18-wheeler is 168 inches.

    Sample Input

     

    180 160 170
    -1

    Sample Output

     

    CRASH 160
    
    
    #include <stdio.h>
    
    int main()
    {
        int i;
    	int j;
    	int t;
    	int flag;
    	int num[3];
    
    	while(scanf("%d", &num[0])!=EOF && num[0]>=0)
    	{
    	      scanf("%d %d", &num[1], &num[2]);
              
    		  flag=0;
    
    		  for(i=0; i<2; i++)
    		  {
    		     for(j=i+1; j<3; j++) 
    			 {
    			     if(num[i]>num[j])
    				 {
    				    t= num[i];
    					num[i]= num[j];
    					num[j]= t;
    				 }
    			 }
    		  }
    
    		  for(i=0; i<3; i++)
    		  {
    		      if(num[i]<=168)
    			  {
    			      flag=1;
    				  break;
    			  }
    		  }
    
    		  if(flag)
    		  {
    		     printf("CRASH %d\n", num[i]);
    		  }
    		  else
    		  {
    		      printf("NO CRASH\n");
    		  }
    	}
        
        return 0;
    }

    
    
    
    
  • 相关阅读:
    luogu P4587 [FJOI2016]神秘数
    luogu P4042 [AHOI2014/JSOI2014]骑士游戏
    luogu P2597 [ZJOI2012]灾难
    一则胡乱科普
    NJU Static Program Analysis 09: Pointer Analysis II
    NJU Static Program Analysis 08: Pointer Analysis I
    NJU Static Program Analysis 07: Interprocedural Analysis
    NJU Static Program Analysis 06: Data Flow Analysis IV
    LianYunGang OI Camp: Contest #2
    NJU Static Program Analysis 05: Data Flow Analysis III
  • 原文地址:https://www.cnblogs.com/xinyuyuanm/p/3053024.html
Copyright © 2011-2022 走看看