zoukankan      html  css  js  c++  java
  • 【ACM】poj_2092_Grandpa is Famous_201308021920

    Grandpa is Famous
    Time Limit: 2000MS  Memory Limit: 30000K
    Total Submissions: 7256  Accepted: 3670

    Description

    The whole family was excited by the news. Everyone knew grandpa had been an extremely good bridge player for decades, but when it was announced he would be in the Guinness Book of World Records as the most successful bridge player ever, whow, that was astonishing!
    The International Bridge Association (IBA) has maintained, for several years, a weekly ranking of the best players in the world. Considering that each appearance in a weekly ranking constitutes a point for the player, grandpa was nominated the best player ever because he got the highest number of points.
    Having many friends who were also competing against him, grandpa is extremely curious to know which player(s) took the second place. Since the IBA rankings are now available in the internet he turned to you for help. He needs a program which, when given a list of weekly rankings, finds out which player(s) got the second place according to the number of points.
    Input

    The input contains several test cases. Players are identified by integers from 1 to 10000. The first line of a test case contains two integers N and M indicating respectively the number of rankings available (2 <= N <= 500) and the number of players in each ranking (2 <= M <= 500). Each of the next N lines contains the description of one weekly ranking. Each description is composed by a sequence of M integers, separated by a blank space, identifying the players who figured in that weekly ranking. You can assume that:

    in each test case there is exactly one best player and at least one second best player,

    each weekly ranking consists of M distinct player identifiers.

    The end of input is indicated by N = M = 0.
    Output

    For each test case in the input your program must produce one line of output, containing the identification number of the player who is second best in number of appearances in the rankings. If there is a tie for second best, print the identification numbers of all second best players in increasing order. Each identification number produced must be followed by a blank space.
    Sample Input

    4 5
    20 33 25 32 99
    32 86 99 25 10
    20 99 10 33 86
    19 33 74 99 32
    3 6
    2 34 67 36 79 93
    100 38 21 76 91 85
    32 23 85 31 88 1
    0 0
    Sample Output

    32 33
    1 2 21 23 31 32 34 36 38 67 76 79 88 91 93 100
    Source


    题意:爷爷打桥牌很厉害,拿得冠军。但是他还想知道,除了他,那些选手是第二(或者并列第二)。现已知每场比赛,有名次的选手的编号,请根据获得名次的次数的多少判定选手的排名,求第二(或者并列第二)的选手的编号。


    #include <stdio.h>
    #define MAX_LEN 10100
    int sz[MAX_LEN];
    int main()
    {
     int n,m;
     while(scanf("%d %d",&n,&m),n||m)
     {
      int i,j,a,b=0;  
      memset(sz,0,sizeof(sz));
      for(i=0;i<n;i++)
      for(j=0;j<m;j++)
      {
       scanf("%d",&a);
       sz[a]++;
      }
      for(i=1;i<MAX_LEN;i++)
      {
       if(sz[i]==0)
       continue;
       else if(sz[i]>sz[0])
       sz[0]=sz[i];
      }
      for(i=1;i<MAX_LEN;i++)
      {
       if((sz[i]==sz[0])||(sz[i]==0))
       continue;
       else if(sz[i]>b)
       b=sz[i];
      }
      for(i=1;i<MAX_LEN;i++)
      {
       if(sz[i]==b)
       printf("%d ",i);
      }
      printf(" ");
     }
     return 0;
    }

  • 相关阅读:
    [Bug] .NET 2.0 的Bug —— ComboBox中不能添加Component.
    [WPF]WPF中如何实现数据与表示分离。(一) —— XAML
    我有2个Windows Live Messenger的邀请。
    Avalon学习笔记 之 路由事件
    [FxCop.设计规则]10. 类型应该被声明在命名空间中
    Avalon学习笔记(二)——从属属性 和 附加属性
    Longhorn将集成RSS支持。
    [WinFX]WinFX 12月份CTP发布,其中包含了XAML设计器
    [FxCop.设计规则]9. 事件句柄声明不恰当
    对于最近一段时间热门的新技术的感想
  • 原文地址:https://www.cnblogs.com/xl1027515989/p/3233458.html
Copyright © 2011-2022 走看看