zoukankan      html  css  js  c++  java
  • poj2456 二分逼近寻找正确答案

    Aggressive cows
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 10078   Accepted: 4988

    Description

    Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

    His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

    Input

    * Line 1: Two space-separated integers: N and C

    * Lines 2..N+1: Line i+1 contains an integer stall location, xi

    Output

    * Line 1: One integer: the largest minimum distance

    Sample Input

    5 3
    1
    2
    8
    4
    9

    Sample Output

    3

    Hint

    OUTPUT DETAILS:

    FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

    Huge input data,scanf is recommended.
    解析见代码:
    #include <iostream>
    #include <cstdio>
    #include <string>
    #include <cmath>
    #include <iomanip>
    #include <ctime>
    #include <climits>
    #include <cstdlib>
    #include <cstring>
    #include <algorithm>
    #include <queue>
    #include <vector>
    #include <set>
    #include <map>
    using namespace std;
    const int maxn=100000+100;
    int a[maxn];
    int n,c;
    bool check(int dis)
    {
        int last=0;
        for(int i=1;i<c;i++)//放置c头牛,共有c-1个空
        {
            int next=last+1;//next初始化
            while(next<n&&a[next]-a[last]<dis) next++;//直到寻找到满足条件的next:
            if(next>=n) return false;
            last=next;//更新last
        }
        return true;
    }
    int main()
    {
        int ans;
        while(scanf("%d%d",&n,&c)!=EOF)
        {
            for(int i=0;i<n;i++)
                scanf("%d",&a[i]);
            sort(a,a+n);//使用二分逼近的方法确定答案,首先必须保证数组单调
            int l=0,r=a[n-1]+1;//枚举的是距离,范围是0~a[n-1]+1;
            while(l<=r)
            {
                int mid=(l+r)>>1;
                if(check(mid)) ans=mid,l=mid+1;//满足条件,更新答案。
                else r=mid-1;
            }
            printf("%d ",ans);
        }
     return 0;
    }
  • 相关阅读:
    每天一点点java---继承exception类来实现自己的异常类
    由Java代码运行shell命令/脚本
    虚拟现实及增强现实(眼镜或头盔)现状与未来-基本介绍
    Struts2大约Action系统培训6大约action的接受三个参数的方法
    main真正的形状函数
    为了交易-存储过程
    Oracle 数据库 JOB 失败后解密法重试
    [ACM] ZOJ 3816 Generalized Palindromic Number (DFS,暴力枚举)
    十依据一个有用的算法来找到最小(最大)的k的数量-线性搜索算法
    Maven配置
  • 原文地址:https://www.cnblogs.com/xuejianye/p/5503005.html
Copyright © 2011-2022 走看看