zoukankan      html  css  js  c++  java
  • ZOJ 3829 Known Notation 贪心 难度:0

    Known Notation

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    Do you know reverse Polish notation (RPN)? It is a known notation in the area of mathematics and computer science. It is also known as postfix notation since every operator in an expression follows all of its operands. Bob is a student in Marjar University. He is learning RPN recent days.

    To clarify the syntax of RPN for those who haven't learnt it before, we will offer some examples here. For instance, to add 3 and 4, one would write "3 4 +" rather than "3 + 4". If there are multiple operations, the operator is given immediately after its second operand. The arithmetic expression written "3 - 4 + 5" in conventional notation would be written "3 4 - 5 +" in RPN: 4 is first subtracted from 3, and then 5 added to it. Another infix expression "5 + ((1 + 2) × 4) - 3" can be written down like this in RPN: "5 1 2 + 4 × + 3 -". An advantage of RPN is that it obviates the need for parentheses that are required by infix.

    In this problem, we will use the asterisk "*" as the only operator and digits from "1" to "9" (without "0") as components of operands.

    You are given an expression in reverse Polish notation. Unfortunately, all space characters are missing. That means the expression are concatenated into several long numeric sequence which are separated by asterisks. So you cannot distinguish the numbers from the given string.

    You task is to check whether the given string can represent a valid RPN expression. If the given string cannot represent any valid RPN, please find out the minimal number of operations to make it valid. There are two types of operation to adjust the given string:

    1. Insert. You can insert a non-zero digit or an asterisk anywhere. For example, if you insert a "1" at the beginning of "2*3*4", the string becomes "12*3*4".
    2. Swap. You can swap any two characters in the string. For example, if you swap the last two characters of "12*3*4", the string becomes "12*34*".

    The strings "2*3*4" and "12*3*4" cannot represent any valid RPN, but the string "12*34*" can represent a valid RPN which is "1 2 * 34 *".

    Input

    There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

    There is a non-empty string consists of asterisks and non-zero digits. The length of the string will not exceed 1000.

    Output

    For each test case, output the minimal number of operations to make the given string able to represent a valid RPN.

    Sample Input

    3
    1*1
    11*234**
    *
    

    Sample Output

    1
    0
    2
    一开始的时候若不够lenofstar+1,放置lenofstar+1-lenofnumber个数字在前面,然后对不满足formerlenofnumber==formerlenofstar+1的星号都调到最后面和数字交换就行,注意最后一个如果是数字再和星号换回来
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    char maz[2000];
    int len,lenstar,addnum,addstar,lennum;
    int main(){
        int T;
        scanf("%d",&T);
        while(T--){
            scanf("%s",maz);
            len=strlen(maz);addstar=lenstar=addnum=lennum=0;
            for(int i=0;i<len;i++){
                if(maz[i]=='*')lenstar++;
                else lennum++;
            }
            if(lenstar==0){
                puts("0");
                continue;
            }
            int op=0;
            if(lennum<lenstar+1){
                addnum=lenstar+1-lennum;
            }
            op+=addnum;
            int bakpnt=len;
            for(int i=0;i<len;i++){
                if(maz[i]=='*'){
                    if(addnum<addstar+2){
                        bakpnt--;
                        while(maz[bakpnt]=='*'){
                            bakpnt--;
                        }
                        swap(maz[bakpnt],maz[i]);
                        op++;
                    }
                }
                if(maz[i]=='*')addstar++;
                else addnum++;
            }
            if(maz[len-1]!='*')op++;
            printf("%d\n",op);
        }
        return 0;
    }
    

      

  • 相关阅读:
    mongodb性能测试:long时间戳与string格式时间
    .netcore mongodb 分页+模糊查询+多条件查询
    .netcore 图片处理
    ELEMENT-UI 封装el-table 局部刷新row
    vue-upload 封装组件-上传组件
    vue实现v-model父子组件间的双向通信
    cc.AudioSource
    Chrome插件:本地程序实现验证码破解(浏览器与本地进程通信)
    Chrome插件:微信公众号自动登录(chrome.extension)
    Chrome插件:浏览器后台与页面间通信
  • 原文地址:https://www.cnblogs.com/xuesu/p/4021075.html
Copyright © 2011-2022 走看看