zoukankan      html  css  js  c++  java
  • ZOJ 3822 Domination 概率dp 难度:0

    Domination

    Time Limit: 8 Seconds      Memory Limit: 131072 KB      Special Judge

    Edward is the headmaster of Marjar University. He is enthusiastic about chess and often plays chess with his friends. What's more, he bought a large decorative chessboard with N rows and M columns.

    Every day after work, Edward will place a chess piece on a random empty cell. A few days later, he found the chessboard was dominated by the chess pieces. That means there is at least one chess piece in every row. Also, there is at least one chess piece in every column.

    "That's interesting!" Edward said. He wants to know the expectation number of days to make an empty chessboard of N × M dominated. Please write a program to help him.

    Input

    There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

    There are only two integers N and M (1 <= NM <= 50).

    Output

    For each test case, output the expectation number of days.

    Any solution with a relative or absolute error of at most 10-8 will be accepted.

    Sample Input

    2
    1 3
    2 2
    

    Sample Output

    3.000000000000
    2.666666666667
    

     概率dp

    #include<cstdio>
    #include<cstring>
    using namespace std;
    double dp[60][60][3000];
    void printdp(int x,int y){
        for(int i=0;i<=x;i++){
            for(int j=0;j<=y;j++){
                for(int k=0;k<=i*j;k++){
                    printf("dp[%d][%d][%d]%f ",i,j,k,dp[i][j][k]);
                }
            }
            puts("");
        }
    }
    int main(){
        int T;
        int n,m;
        scanf("%d",&T);
        while(T--){
            scanf("%d%d",&n,&m);
            for(int i=0;i<=n;i++){
                for(int j=0;j<=m;j++){
                    memset(dp[i][j],0,sizeof(dp[i][j]));
                }
            }
            dp[0][0][0]=1;
            for(int i=0;i<=n;i++){
                for(int j=0;j<=m;j++){
                    for(int k=0;k<=i*j;k++){
                        if(k==n*m||(i==n&&j==m)) continue;
                        if(k<i*j)dp[i][j][k+1]+=dp[i][j][k]*(i*j-k)/(n*m-k);
                        if(i<n)dp[i+1][j][k+1]+=dp[i][j][k]*(n-i)*j/(n*m-k);
                        if(j<m)dp[i][j+1][k+1]+=dp[i][j][k]*(m-j)*i/(n*m-k);
                        if(i<n&&j<m)dp[i+1][j+1][k+1]+=dp[i][j][k]*(n-i)*(m-j)/(n*m-k);
                    }
                }
            }
            double sum=0;
            for(int k=0;k<=n*m;k++){
                sum+=k*dp[n][m][k];
               // sum+=dp[n][m][k];
               // printf("dp[%d]%f\n",k,dp[n][m][k]);
            }
            //printdp(n,m);
            //double ans=(double)sub/(double)sum;
            printf("%.12f\n",sum);
        }
        return 0;
    }
    

      

  • 相关阅读:
    【Nginx学习】安装及常用命令
    【Nginx学习】基础知识
    【Nginx学习】Xshell7连接CentOS7艰难轶事
    【LeetCode刷题】5343. 多次求和构造目标数组:妙解
    【LeetCode刷题】1353. 最多可以参加的会议数目
    【转载】priority_queue用法
    【LeetCode刷题】供暖器:妙解
    【妙解】重复的子字符串
    【转载学习】基金理财学习
    【转载】sync_with_stdio + cin.tie
  • 原文地址:https://www.cnblogs.com/xuesu/p/4021083.html
Copyright © 2011-2022 走看看